problem starting hostapd ioctl errors: no such device

Jouni Malinen j at w1.fi
Thu Nov 8 22:19:46 EST 2007


On Wed, Nov 07, 2007 at 11:55:48AM +0000, Marc Wyburn wrote:

> Hi all,  I have installed hostap and am trying to get hostapd started on a
> Ubuntu Gutsy laptop.  Hostap seems to be running ok as I can get the card
> into master mode and can connect to it.  I tried the Ubuntu package for
> hostapd but it gave "ioctl no such device".  I also compiled it manually but
> still get the same error.  I'm using a Senao Prism2.5 card so didn't make
> changes to the .config file.  The strange thing I have noticed is that
> hostap creates eth2 and wlan0_rename, and if I use either of these names in
> hostapd.conf, I get the "S10CGIFINDEX: no such device error".  If I use
> wlan0, which doesn't appear to be a valid name - it isn't listed by
> iwconfig, I get a ioctl PRISM2_IOCTL_PRISM2_PARAM no such device error.

Host AP driver does not name the interfaces that way; something else has
renamed them and that is breaking hostapd. The current implementation
requires that the interfaces are wlan0 and wlan0ap (or well, to be more
exact, <any prefix> and <any prefix>ap). You will either need to modify
driver_hostap.c to handle this kind of differences in interface names or
stop the renaming from happening.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list