problem starting hostapd ioctl errors: no such device

Marc Wyburn marc.wyburn at googlemail.com
Wed Nov 7 06:55:48 EST 2007


Hi all,  I have installed hostap and am trying to get hostapd started on a
Ubuntu Gutsy laptop.  Hostap seems to be running ok as I can get the card
into master mode and can connect to it.  I tried the Ubuntu package for
hostapd but it gave "ioctl no such device".  I also compiled it manually but
still get the same error.  I'm using a Senao Prism2.5 card so didn't make
changes to the .config file.  The strange thing I have noticed is that
hostap creates eth2 and wlan0_rename, and if I use either of these names in
hostapd.conf, I get the "S10CGIFINDEX: no such device error".  If I use
wlan0, which doesn't appear to be a valid name - it isn't listed by
iwconfig, I get a ioctl PRISM2_IOCTL_PRISM2_PARAM no such device error.

dmesg show invalid skb->cb magic but I haven't worked out what this means
yet.

Can anyone help am I using the incorrect card details or something?

thanks, Marc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20071107/5209f734/attachment.htm 


More information about the HostAP mailing list