problem starting hostapd ioctl errors: no such device

Marc Wyburn marc.wyburn at googlemail.com
Fri Nov 9 05:21:46 EST 2007


I ended up installing Ubuntu Dapper and all is fine.  It seems to be
something to do with the hostap drivers in the later kernel used by Ubuntu
Gutsy.

On 09/11/2007, Jouni Malinen <j at w1.fi> wrote:
>
> On Wed, Nov 07, 2007 at 11:55:48AM +0000, Marc Wyburn wrote:
>
> > Hi all,  I have installed hostap and am trying to get hostapd started on
> a
> > Ubuntu Gutsy laptop.  Hostap seems to be running ok as I can get the
> card
> > into master mode and can connect to it.  I tried the Ubuntu package for
> > hostapd but it gave "ioctl no such device".  I also compiled it manually
> but
> > still get the same error.  I'm using a Senao Prism2.5 card so didn't
> make
> > changes to the .config file.  The strange thing I have noticed is that
> > hostap creates eth2 and wlan0_rename, and if I use either of these names
> in
> > hostapd.conf, I get the "S10CGIFINDEX: no such device error".  If I use
> > wlan0, which doesn't appear to be a valid name - it isn't listed by
> > iwconfig, I get a ioctl PRISM2_IOCTL_PRISM2_PARAM no such device error.
>
> Host AP driver does not name the interfaces that way; something else has
> renamed them and that is breaking hostapd. The current implementation
> requires that the interfaces are wlan0 and wlan0ap (or well, to be more
> exact, <any prefix> and <any prefix>ap). You will either need to modify
> driver_hostap.c to handle this kind of differences in interface names or
> stop the renaming from happening.
>
> --
> Jouni Malinen                                            PGP id EFC895FA
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap
>



-- 
http://www.myspace.com/yburn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20071109/887c03f8/attachment.htm 


More information about the HostAP mailing list