Intersil (AMBIT) Prism 2.5, 3872 chipset

Roberto Guida roberto.guida at tiscali.it
Sat Mar 24 20:45:24 EDT 2007


Hi, thanx for your reply!

Jar ha scritto:
> For better performance the STA: id=0x1f v1.5.6 can be updated to
> STA: id=0x1f v1.7.4. See http://linux.junsun.net/intersil-prism/
>

Very nice mini how-to; thanks a lot.. i did upgrade to 1.7.4.. the
firmware files I have chosen are pk010101.hex and sf010704.hex, also if
this guy says
http://linux.junsun.net/intersil-prism/stories/20051109_Norbert_Preining_ambit_nicid_8022.txt
he chosed a different one (sf010804.hex); we have the same NICID; so for
people that have my same wifi, for me the upgrade was successfull, on 
winXP everything works as before, but on linux now i get from dmesg:

[root at PCGUEST9G9 rob]# dmesg | grep wifi0
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0x0
wifi0: NIC: id=0x8022 v1.0.0
wifi0: PRI: id=0x15 v1.1.1
wifi0: STA: id=0x1f v1.7.4
wifi0: Intersil Prism2.5 PCI: mem=0xe0500000, irq=11
wifi0: registered netdevice wlan0
wifi0: Host AP mode does not support 'Any' essid
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA 33:33:00:00:00:16 for this TX error (@4294768296)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA 33:33:ff:a0:83:d6 for this TX error (@4294769218)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA 33:33:00:00:00:02 for this TX error (@4294770242)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA 33:33:00:00:00:02 for this TX error (@4294774236)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA 33:33:00:00:00:02 for this TX error (@4294778230)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA ff:ff:ff:ff:ff:ff for this TX error (@342875)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA ff:ff:ff:ff:ff:ff for this TX error (@346869)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA ff:ff:ff:ff:ff:ff for this TX error (@357827)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA ff:ff:ff:ff:ff:ff for this TX error (@374930)
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
wifi0: Could not find STA ff:ff:ff:ff:ff:ff for this TX error (@391931)

what are all these errors?

> Forget the wifi0 interface. There should exists wlan0 interface also, 
> which you should use instead of wifi0. 

In fact wlan0 existed before, but i removed (before send u the email) it 
because I thought it was referred to a USB wifi that I have used some 
months ago (supported by another driver, and that worked) and that now i 
didn't need.. how can it appear again?
anyway I have also eth0 (the MAC address i that one of the wifi) and 
i've tried to connect it but it doesn't work, the dmesg error is

wifi0: LinkStatus=2 (Disconnected)

if i try to remove the module (because i would like to remove and then 
load it again) with rmmod it says:
[root at PCGUEST9G9 rob]# rmmod hostap_pci
ERROR: Module hostap_pci is in use

any ideas to help me?
thank u again in advance..
Rob




More information about the HostAP mailing list