Newbie wpa_supplicant question

Kosta Rojdestvensky kosta1000 at gmail.com
Tue Mar 28 17:22:24 EST 2006


Hello,

I'm trying to connect to the corporate wireless network in Ubuntu
Breezy without full knowledge of the server parameters. (My local
network support guys are useless...)
In windows it works under the Funk Odyssey client software.
I was trying several parameters in wpa_supplicant.conf and looks like
I got connected (kind of).
At least I got successful messages in the debug output of supplicant (v0.4.5) :
...
EAPOL: Received EAPOL-Key frame
EAPOL: KEY_RX entering state KEY_RECEIVE
EAPOL: processKey
EAPOL: RX IEEE 802.1X ver=1 type=3 len=44 EAPOL-Key: type=1
key_length=13 key_index=0x83
EAPOL: EAPOL-Key key signature verified
EAPOL: using part of EAP keying material data encryption key -
hexdump(len=13): [REMOVED]EAPOL: Setting dynamic WEP key: unicast
keyidx 3 len 13
wpa_driver_ipw_set_key: alg=WEP key_idx=3 set_tx=128 seq_len=0 key_len=13
EAPOL: all required EAPOL-Key frames received
WPA: EAPOL processing complete
Cancelling authentication timeout
State: ASSOCIATED -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:40:96:52:0a:84 completed (reauth)
EAPOL: SUPP_PAE entering state AUTHENTICATED
...
and output from the wpa_cli looks like
# wpa_cli status
Selected interface 'eth1'
bssid=00:40:96:49:2a:6a
ssid=NULL
pairwise_cipher=NONE
group_cipher=NONE
key_mgmt=IEEE 802.1X (no WPA)
wpa_state=COMPLETED
Supplicant PAE state=AUTHENTICATED
suppPortStatus=Authorized
EAP state=SUCCESS
selectedMethod=25 (EAP-PEAP)
EAP TLS cipher=AES256-SHA
EAP-PEAPv1 Phase2 method=GTC
...

my wpa_supplicant.conf looks like:

ctrl_interface=/var/run/wpa_supplicant
ap_scan=2
network={
       scan_ssid=1
        ssid="NULL"
        key_mgmt=IEEE8021X
        proto=WPA2
        eap=PEAP
        identity="aaaaaaa"
        password="xxxxxxx"
        phase1="peaplabel=0"
        phase2="auth=MSCHAPv2"
        priority=1
}


The problem is that there is no response from the DHCP server at this point.
Am I missing something and the interface is not really connected?
and
    "State: ASSOCIATED -> COMPLETED "
    "CTRL-EVENT-CONNECTED-Connection to 00:40:96:52:0a:84 completed"
messages do not mean 'Really connected' ?

I also tried two different cards (ipw2200, and ath) with the same result...
The same time my collegue just mentioned successful connection on Mac OS
using standard mac software...

Any help or directions are very
appreciated.


Thanks,

Kosta Rozdestvensky



More information about the HostAP mailing list