Newbie wpa_supplicant question

Jouni Malinen jkmaline at cc.hut.fi
Tue Mar 28 22:22:15 EST 2006


On Tue, Mar 28, 2006 at 03:22:24PM -0700, Kosta Rojdestvensky wrote:

> EAPOL: using part of EAP keying material data encryption key -
> hexdump(len=13): [REMOVED]EAPOL: Setting dynamic WEP key: unicast
> keyidx 3 len 13
> wpa_driver_ipw_set_key: alg=WEP key_idx=3 set_tx=128 seq_len=0 key_len=13

Using non-zero key index for unicast keys is against number of standards
and there are drivers that do not support this. I do not remember
whether ipw2x00 handles this or not, but this could explain why the data
connection does not work.

> Am I missing something and the interface is not really connected?
> and
>     "State: ASSOCIATED -> COMPLETED "
>     "CTRL-EVENT-CONNECTED-Connection to 00:40:96:52:0a:84 completed"
> messages do not mean 'Really connected' ?

As far as wpa_supplicant is concerned, everything is done at this point
and the authentication and key distribution was completed successfully.

> I also tried two different cards (ipw2200, and ath) with the same result...

Based on my notes, this kind of configuration has worked with NDIS
drivers (wpa_supplicant on WinXP), Host AP driver, and madwifi (though,
quite an old version). I do not remember having tested this with
ipw2200.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list