wpa_supplicant with EAP-TLS and madwifi driver not authenticating

Shashidhar Lakkavalli shashilv at yahoo.com
Wed Mar 9 18:45:08 EST 2005


Hi,

I am trying to use EAP-TLS with a Linksys PCI card
using the madwifi driver, to communicate with a Cisco
1100 series AP. The configuration file I have used is
as follows:

eapol_version=1
ap_scan=0
# IEEE 802.1X/EAPOL with dynamically generated WEP
keys (i.e., no WPA) using
# EAP-TLS for authentication and key generation;
require both unicast and
# broadcast WEP keys.
network={
        ssid="8021x"
        scan_ssid=0
        proto=WPA
        key_mgmt=IEEE8021X
        eap=TLS
        identity="anonymous"
        anonymous_identity="anonymous"
        ca_cert="/usr/local/etc/1x/certs/root.pem"
       
client_cert="/usr/local/etc/1x/certs/cert-clt.pem"
       
private_key="/usr/local/etc/1x/certs/cert-clt.pem"
        private_key_passwd="whatever"
        eapol_flags=3
}

The wpa_supplicant output file is attached with the
email. The wpa_supplicant is able to send the
EAPOL-Start, receive the EAP request and send the EAP
response. But after that, the AiroPeek sniffer does
not show any communication between the wpa_supplicant
and the AP.

This problem is only with IEEE8021x with dynamic WEP
keys. I was able to get EAP-TLS using WPA, and WPA-PSK
to work.

Please let me know if I am missing something. I have
attached the wpa_supplicant output for reference.

Thanks,
Shashi.


	
		
__________________________________ 
Celebrate Yahoo!'s 10th Birthday! 
Yahoo! Netrospective: 100 Moments of the Web 
http://birthday.yahoo.com/netrospective/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wpa_out
Type: application/octet-stream
Size: 9531 bytes
Desc: wpa_out
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20050309/5d05b41e/attachment.obj 


More information about the HostAP mailing list