Association to an unsecured AP.

Scott Robinson scott at
Sat Dec 17 00:49:26 EST 2005

I have spent several hours trying to track down the broken association
with unencrypted AP bug. (As described in bugs #30, #38 and #60.) I
initially noticed it when roaming between encrypted APs (which work
fine, WPA and WEP) to unencrypted APs. (in Cafes and friends' homes)

My initial thought was toward the DROP_UNENCRYPTED, COUNTERMEASURES, or
wireless keys remaining active in driver configuration. However, after
extensive debugging and work I have determined none of these are the

I'm using ndiswrapper and am capable of testing patches. I haven't tried
testing against CVS HEAD, but it's on my TODO list.

My debugging strongly indicates the bug to exist in the association
code. That is, for whatever reason, the association call to the
driver_ndiswrapper is failing.

Worse, when ndiswrapper is closed, whatever has caused the association
to fail is continuing to exist in the driver. I am unable to use
iwconfig/iwpriv to return the interface to a usable state. modprobe -r
is the order of the day...

I'd love to help track this bug down. Let me know what I haven't tried!
I don't have a lot of experience with Linux wireless, so that limits me
for the moment.


--            - Personal webpage
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : 

More information about the HostAP mailing list