Problem bringing up Netgear WG511 interface

Neil Jerram neil at ossau.uklinux.net
Sun Dec 19 12:51:30 EST 2004


Hi Steven,

Steven Ihde wrote:
> You need to run wpa_supplicant before pump.  No traffic other than the
> WPA authentication will be able to pass before WPA is complete.  You
> need to "ifconfig" the interface up before running wpa_supplicant. [...]

Many thanks - this is exactly the kind of information that I was looking 
for.

Unfortunately, something is still not quite right, though, so I'll 
describe exactly what I'm now doing, and what results I'm seeing.

(From the very beginning ...)

1. I added prism54 to /etc/hotplug/blacklist so that the kernel doesn't 
load the prism54 driver automatically when the card is plugged in.

2. I installed ndiswrapper and the Windows drivers from the Win2K 
directory on the Netgear CD.

root at laruns:/home/neil# ndiswrapper -l
Installed ndis drivers:
netwg511        driver present, hardware present

3. I installed the ndiswrapper module using "modprobe ndiswrapper".

root at laruns:/home/neil# lsmod | grep 'ndis\|prism'
ndiswrapper           115184  0
usbcore               119012  5 ndiswrapper,usbhid,uhci_hcd

4. ifconfig now shows the wireless interface as wlan0:

root at laruns:/home/neil# ifconfig -a
...
wlan0     Link encap:Ethernet  HWaddr 00:09:5B:EF:34:47
           BROADCAST MULTICAST  MTU:1500  Metric:1
           RX packets:12 errors:0 dropped:0 overruns:0 frame:0
           TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:1580 (1.5 KiB)  TX bytes:9120 (8.9 KiB)
           Interrupt:11 Memory:10400000-10401fff

5. And iwconfig as:

root at laruns:/home/neil# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:off/any
           Mode:Managed  Frequency:2.462 GHz  Access Point: 
00:00:00:00:00:00
           Bit Rate:2 Mb/s   Tx-Power:32 dBm
           RTS thr:2347 B   Fragment thr:2346 B
           Encryption key:off
           Power Management:off
           Link Quality:86  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:17  Invalid misc:3063   Missed beacon:0

6. Do the wireless config and bring the interface up:

root at laruns:/home/neil# iwconfig wlan0 mode Managed
root at laruns:/home/neil# iwconfig wlan0 essid "122 King's Cross Road"
root at laruns:/home/neil# ifconfig wlan0 up
root at laruns:/home/neil# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:off/any
           Mode:Managed  Frequency:2.462 GHz  Access Point: 
00:00:00:00:00:00
           Bit Rate:2 Mb/s   Tx-Power:32 dBm
           RTS thr:2347 B   Fragment thr:2346 B
           Encryption key:off
           Power Management:off
           Link Quality:86  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:17  Invalid misc:3082   Missed beacon:0

root at laruns:/home/neil# ifconfig -a
...
wlan0     Link encap:Ethernet  HWaddr 00:09:5B:EF:34:47
           inet6 addr: fe80::209:5bff:feef:3447/64 Scope:Link
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:12 errors:0 dropped:0 overruns:0 frame:0
           TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:1580 (1.5 KiB)  TX bytes:9498 (9.2 KiB)
           Interrupt:11 Memory:10400000-10401fff

7. Run wpa_supplicant (in another window, so this continues running 
during the following steps):

root at laruns:/etc# wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -d 
-Dndiswrapper
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=100 (from group name 'users')
eapol_version=1
ap_scan=1
Priority group 50
    id=0 ssid='122 King's Cross Road'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 100000 usec
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 560 bytes of scan results (2 BSSes)
Scan results: 2
Selecting BSS from priority group 50
0: 00:0f:b5:18:d3:62 ssid='122 King's Cross Road' wpa_ie_len=24 rsn_ie_len=0
    selected
Trying to associate with 00:0f:b5:18:d3:62 (SSID='122 King's Cross Road' 
freq=2462 MHz)
Cancelling scan request
WPA: using IEEE 802.11i/D3.0
WPA: Own WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 
01 00 00 50 f2 02 01 00 00 50 f2 02
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8c02 len=197
Custom wireless event: 
'ASSOCINFO(ReqIEs=0015313232204b696e6727732043726f737320526f6164010402040b1632080c1218243048606cdd160050f20101000050f20201000050f20201000050f202 
RespIEs=010482848b9632080c1218243048606c)'
Association info event
req_ies - hexdump(len=63): 00 15 31 32 32 20 4b 69 6e 67 27 73 20 43 72 
6f 73 73 20 52 6f 61 64 01 04 02 04 0b 16 32 08 0c 12 18 24 30 48 60 6c 
dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
assoc_wpa_ie - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 
00 00 50 f2 02 01 00 00 50 f2 02
RX EAPOL from 00:0f:b5:18:d3:62
Setting authentication timeout: 10 sec 0 usec
EAPOL: Ignoring WPA EAPOL-Key frame in EAPOL state machines
IEEE 802.1X RX: version=1 type=3 length=95
   EAPOL-Key type=254
WPA: RX message 1 of 4-Way Handshake from 00:0f:b5:18:d3:62 (ver=1)
WPA: Renewed SNonce - hexdump(len=32): 86 a0 47 e6 4c 46 f3 67 f8 eb 9f 
95 eb 56 f3 c1 eb 2d 7b 00 5a 0e bb 4f 05 67 f6 22 9b c4 86 2f
WPA: PMK - hexdump(len=32): d5 f4 dd 96 80 58 7b b4 05 12 10 ed c7 4c 90 
32 7b cf 6c 12 53 9f 4f 8f f0 a1 58 17 0e 53 5d eb
WPA: PTK - hexdump(len=64): 6f f2 67 2c 4a 82 c3 17 d3 c4 6b a2 44 ee 12 
0b 7c 52 17 68 be 33 6e 66 db bc b2 7b 55 a7 95 90 ea d4 cc d1 37 a5 33 
de 82 c2 40 dc 92 76 d6 2a ca fd 7e 2e ff 5e 39 a9 11 d7 9c 23 8d e5 20 cb
WPA: EAPOL-Key MIC - hexdump(len=16): 0b 4a 44 c3 8c 04 c5 6f 6c 6f 86 
80 cb 1b 7a 85
WPA: Sending EAPOL-Key 2/4
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:0f:b5:18:d3:62
Association event - clear replay counter
Associated to a new BSS: BSSID=00:0f:b5:18:d3:62
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state CONNECTING
EAPOL: txStart
WPA: drop TX EAPOL in non-IEEE 802.1X mode (type=1 len=0)
EAPOL: SUPP_BE entering state IDLE
EAP: EAP entering state INITIALIZE
EAP: EAP entering state IDLE
Setting authentication timeout: 10 sec 0 usec
Wireless event: cmd=0x8c02 len=197
Custom wireless event: 
'ASSOCINFO(ReqIEs=0015313232204b696e6727732043726f737320526f6164010402040b1632080c1218243048606cdd160050f20101000050f20201000050f20201000050f202 
RespIEs=010482848b9632080c1218243048606c)'
Association info event
req_ies - hexdump(len=63): 00 15 31 32 32 20 4b 69 6e 67 27 73 20 43 72 
6f 73 73 20 52 6f 61 64 01 04 02 04 0b 16 32 08 0c 12 18 24 30 48 60 6c 
dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
assoc_wpa_ie - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 
00 00 50 f2 02 01 00 00 50 f2 02
Wireless event: cmd=0x8b15 len=20
Wireless event: new AP: 00:0f:b5:18:d3:62
Association event - clear replay counter
EAPOL: External notification - portValid=0
EAPOL: External notification - EAP success=0
EAPOL: External notification - portEnabled=1
Setting authentication timeout: 10 sec 0 usec
RX EAPOL from 00:0f:b5:18:d3:62
Setting authentication timeout: 10 sec 0 usec
EAPOL: Ignoring WPA EAPOL-Key frame in EAPOL state machines
IEEE 802.1X RX: version=1 type=3 length=119
   EAPOL-Key type=254
WPA: RX message 3 of 4-Way Handshake from 00:0f:b5:18:d3:62 (ver=1)
WPA: Sending EAPOL-Key 4/4
WPA: Installing PTK to the driver.
WPA: RSC - hexdump(len=6): 00 00 00 00 00 00
RX EAPOL from 00:0f:b5:18:d3:62
EAPOL: Ignoring WPA EAPOL-Key frame in EAPOL state machines
IEEE 802.1X RX: version=1 type=3 length=127
   EAPOL-Key type=254
WPA: RX message 1 of Group Key Handshake from 00:0f:b5:18:d3:62 (ver=1)
WPA: Group Key - hexdump(len=32): 61 97 99 b6 91 fc 76 e8 b9 81 2e 01 75 
3a 5b 37 6f 64 2a 9c ab f1 d0 c4 9a 7e 6b de 6c 0f de 3e
WPA: Installing GTK to the driver (keyidx=2 tx=0).
WPA: RSC - hexdump(len=6): 00 00 00 00 00 00
WPA: Sending EAPOL-Key 2/2
WPA: Key negotiation completed with 00:0f:b5:18:d3:62
Cancelling authentication timeout
EAPOL: External notification - portValid=1
EAPOL: External notification - EAP success=1
EAPOL: SUPP_PAE entering state AUTHENTICATING
EAPOL: SUPP_BE entering state SUCCESS
EAP: EAP entering state SUCCESS
EAPOL: SUPP_PAE entering state AUTHENTICATED
EAPOL: SUPP_BE entering state IDLE

8. The wpa_supplicant output looks good to me, and at this point 
ifconfig still says that the interface is up:

root at laruns:/home/neil# ifconfig -a
...
wlan0     Link encap:Ethernet  HWaddr 00:09:5B:EF:34:47
           inet6 addr: fe80::209:5bff:feef:3447/64 Scope:Link
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:15 errors:0 dropped:0 overruns:0 frame:0
           TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:1975 (1.9 KiB)  TX bytes:9861 (9.6 KiB)
           Interrupt:11 Memory:10400000-10401fff

root at laruns:/home/neil# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:off/any
           Mode:Managed  Frequency:2.462 GHz  Access Point: 
00:00:00:00:00:00
           Bit Rate:2 Mb/s   Tx-Power:32 dBm
           RTS thr:2347 B   Fragment thr:2346 B
           Encryption key:off
           Power Management:off
           Link Quality:87/100  Signal level:-52 dBm  Noise level:-256 dBm
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:17  Invalid misc:3144   Missed beacon:0

9. Finally the DHCP step.

root at laruns:/home/neil# pump -i wlan0
Operation failed.

(There is a delay of around 30 seconds before pump says "Operation failed".)

I ran Ethereal throughout, for all traffic on wlan0, and the results and 
in the eth.txt attachment.  In summary, it shows 6 EAPOL packets (3 each 
way) and 6 DHCP Discover packets from my laptop, but nothing DHCP-wise 
in return.


So, any ideas as to what is still not quite right?  If you need any 
further debug output, please don't hesitate to ask!

Many thanks to all who are reading this!

	Neil
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: eth.txt
Url: http://lists.shmoo.com/pipermail/hostap/attachments/20041219/856b56c5/attachment.txt 


More information about the HostAP mailing list