hostap hangs when reseting..

Lukas Zvonar lukic at mag-net.sk
Mon May 12 17:18:55 EDT 2003


Hi!
Can anybody try this?
One machine (say A), have eth0
second machine (say B) have br0, where belongs eth0  (connected to A) and
hostap in ap mode wlan0 (i think it will do the same, if there is no
bridgeing, just pure ip routing, the problem is - IMHO - recieved packet
when card reset occurs).
third machine (say C) is client (i have IBM laptop with Win98 and orinoco
PCMCIA - it do not depend on it).
Machine C starts data transfer with A, for exaple i used flood ping from A
to C (ping -f -s 500 IPofMachineC)
then on machine B i simulate signal lost - when often reset of card occurs
caused by TX timeout - i just run: iwpriv wlan0 reset 1
And - thats the problem, on some reset (for sure is less then 30 in count) ,
machine B hangs..
I think when card is reseting and some packet is recieved..
last CVS version did'n solved the problem... :-((
I have used D-Link DWL 520 card in machine B, and RH linux with kernel
2.4.7-10 (standard installation)...
I have also tried various firmwares (1.3.6,1.4.9,1.5.6) with the same
result, and also debian linux with 2.4.20 kernel, with of course same
results..

I'm near sure, that it's problem of hostap, because i have seen that many
people writes about unidentified hangs of machines where hostap is used..
So, can anybody try this to ensure me, that is not HW problem of D-Link 520,
or kernel problem (in which i don't believe, because all other things is
running properly and system hangs just right after reset of card is
started).

Lukic

N49° 02,40' E19° 43,07'




More information about the HostAP mailing list