hostap hangs when reseting..

Milan Krcmar milan.krcmar at seznam.cz
Tue May 13 10:19:02 EDT 2003


I've seen many times the idea of receiving a frame during reset causing
total machine lockup. Is there a reason (proof) for this assumption?

I have had several (about 5) computers with PRISM2.5 PCI card and hostap
and can confirm that card reset (should it be triggered on user's behalf
from iwpriv or from some control condition in hostap) sometimes locks the
machine (and only hard reset can recover).

It is a property of each and every computer with PRISM and hostap I know
of. This is experience of a large user group counting several tens of
hostap based APs. Various hardware used for computer itself, card mostly
Zcomax Xi626, but also DLink 520 and so on).

The only way to make the hostap behave stably is to avoid resets (the most
frequent reason hostap shedules card reset seems to be weak signal from AP
while it is in Managed mode, I just had to use a better antenna).

Milan

On Mon, May 12, 2003 at 11:18:55PM +0200, Lukas Zvonar wrote:
> Hi!
> Can anybody try this?
> One machine (say A), have eth0
> second machine (say B) have br0, where belongs eth0  (connected to A) and
> hostap in ap mode wlan0 (i think it will do the same, if there is no
> bridgeing, just pure ip routing, the problem is - IMHO - recieved packet
> when card reset occurs).
> third machine (say C) is client (i have IBM laptop with Win98 and orinoco
> PCMCIA - it do not depend on it).
> Machine C starts data transfer with A, for exaple i used flood ping from A
> to C (ping -f -s 500 IPofMachineC)
> then on machine B i simulate signal lost - when often reset of card occurs
> caused by TX timeout - i just run: iwpriv wlan0 reset 1
> And - thats the problem, on some reset (for sure is less then 30 in count) ,
> machine B hangs..
> I think when card is reseting and some packet is recieved..
> last CVS version did'n solved the problem... :-((
> I have used D-Link DWL 520 card in machine B, and RH linux with kernel
> 2.4.7-10 (standard installation)...
> I have also tried various firmwares (1.3.6,1.4.9,1.5.6) with the same
> result, and also debian linux with 2.4.20 kernel, with of course same
> results..
> 
> I'm near sure, that it's problem of hostap, because i have seen that many
> people writes about unidentified hangs of machines where hostap is used..
> So, can anybody try this to ensure me, that is not HW problem of D-Link 520,
> or kernel problem (in which i don't believe, because all other things is
> running properly and system hangs just right after reset of card is
> started).
> 
> Lukic
> 
> N49° 02,40' E19° 43,07'
> 
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap



More information about the HostAP mailing list