Fwd:iwconfig failures

larry.leblanc at shaw.ca larry.leblanc at shaw.ca
Mon May 12 13:59:46 EDT 2003


Hi Jouni,

I've loaded hostap-0.0.2 and I still have the same problems, although there is now a mention of interrupt problems in the boot messages. Here is the complete output of dmesg - note the "wlan0: interrupt delivery does not seem to work" messages - they did not appear before. Let me know if you find anything....

Thanks,

Larry

Linux version 2.4.20 (root at trim1) (gcc version 3.2.2) #3 Fri May 9 19:49:33 PDT 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f400 (usable)
 BIOS-e820: 000000000009f400 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000d0000 - 00000000000d4000 (reserved)
 BIOS-e820: 00000000000e5c00 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000004000000 (usable)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
64MB LOWMEM available.
On node 0 totalpages: 16384
zone(0): 4096 pages.
zone(1): 12288 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=slack9 ro root=305
Initializing CPU#0
Console: colour VGA+ 80x25
Calibrating delay loop... 39.93 BogoMIPS
Memory: 62152k/65536k available (1260k kernel code, 2996k reserved, 471k data, 116k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Dentry cache hash table entries: 8192 (order: 4, 65536 bytes)
Inode cache hash table entries: 4096 (order: 3, 32768 bytes)
Mount-cache hash table entries: 1024 (order: 1, 8192 bytes)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
CPU:     After generic, caps: 00000000 00000000 00000000 00000000
CPU:             Common caps: 00000000 00000000 00000000 00000000
CPU: Cyrix Cx486DX4
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch at atnf.csiro.au)
mtrr: detected mtrr type: none
PCI: PCI BIOS revision 2.10 entry at 0xfd93c, last bus=0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router default [1078/0400] at 00:12.0
PCI: Cannot allocate resource region 0 of device 00:00.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Starting kswapd
VFS: Diskquotas version dquot_6.4.0 initialized
Journalled Block Device driver loaded
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PCI_IDE: unknown IDE controller on PCI bus 00 device 92, VID=1078, DID=0402
PCI_IDE: chipset revision 1
PCI_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1040-0x1047, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0x1048-0x104f, BIOS settings: hdc:pio, hdd:pio
hda: FUJITSU MHS2020AT, ATA DISK drive
hdb: 56X CD-ROM, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
blk: queue c0307e24, I/O limit 4095Mb (mask 0xffffffff)
hda: 39070080 sectors (20004 MB) w/2048KiB Cache, CHS=2432/255/63, (U)DMA
ide-floppy driver 0.99.newide
Partition check:
 hda:hda: dma_intr: bad DMA status (dma_stat=10)
hda: dma_intr: status=0x50 { DriveReady SeekComplete }
hda: dma_intr: bad DMA status (dma_stat=10)
hda: dma_intr: status=0x50 { DriveReady SeekComplete }
hda: dma_intr: bad DMA status (dma_stat=10)
hda: dma_intr: status=0x50 { DriveReady SeekComplete }
hda: dma_intr: bad DMA status (dma_stat=10)
hda: dma_intr: status=0x50 { DriveReady SeekComplete }
hda: DMA disabled
ide0: unexpected interrupt, status=0xd0, count=1
ide0: reset: success
 hda1 hda2 hda3 hda4 < hda5 hda6 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 8192)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 116k freed
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,5), internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,6), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw at saw.sw.com.sg> and others
PCI: Guessed IRQ 11 for device 00:0a.0
divert: allocating divert_blk for eth0
eth0: OEM i82557/i82558 10/100 Ethernet, 00:07:32:01:98:6B, IRQ 11.
  Receiver lock-up bug exists -- enabling work-around.
  Board assembly 727095-002, Physical connectors present: RJ45
  Primary interface chip i82555 PHY #1.
  General self-test: passed.
  Serial sub-system self-test: passed.
  Internal registers self-test: passed.
  ROM checksum self-test: passed (0xdbd8681d).
  Receiver lock-up workaround activated.
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Intel PCIC probe: 
  Vadem VG-468 ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: none
    host opts [1]: none
    ISA irqs (default) = 3,4,5,7,9,10,11,12,15 polling interval = 1000 ms
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x218-0x21f 0x320-0x327 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xd5fff
cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcbfff
hostap_crypt: registered algorithm 'NULL'
hostap_cs: hostap_cs.c 0.0.0 2002-10-12 (SSH Communications Security Corp, Jouni Malinen)
hostap_cs: (c) Jouni Malinen <jkmaline at cc.hut.fi>
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
prism2_config()
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
divert: allocating divert_blk for wlan0
hostap_cs: Registered netdevice wlan0
prism2_hw_init()
prism2_hw_config: initialized in 25559 iterations
wlan0: NIC: id=0x801b v1.0.0
wlan0: PRI: id=0x15 v1.1.0
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10fdf50, type=0, cmd=0x0021, param0=0xfd20)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
Could not get RID for component STA
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10fdf50, type=0, cmd=0x0021, param0=0xfd20)
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fd20, len=8)
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8021
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_get_rid: CMDCODE_ACCESS failed (res=-110, rid=fc01, len=6)
wlan0: could not get own MAC address
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: hfa384x_set_rid: CMDCODE_ACCESS_WRITE failed (res=-110, rid=fc00, len=2)
wlan0: Port type setting to 6 failed
wlan0: hfa384x_cmd_issue: cmd reg was busy for 1000 usec
wlan0: hfa384x_cmd_issue - timeout - reg=0x8000
wlan0: hfa384x_cmd: entry still in list? (entry=c10fdf50, type=0, res=-1)
wlan0: hfa384x_cmd: interrupted; err=-110
wlan0: MAC port 0 enabling failed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 06:53:04 May  7 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
uhci.c: USB Universal Host Controller Interface driver v1.1
usb.c: deregistering driver usbdevfs
usb.c: deregistering driver hub





More information about the HostAP mailing list