Performance degradation with WEP enabled

Jouni Malinen jkmaline at cc.hut.fi
Tue Jan 28 23:10:52 EST 2003


On Tue, Jan 28, 2003 at 07:54:17PM -0500, Jihong Kim wrote:

> With open system (no encryption), I got about 4.7 Mbps (GUI,
> daemons/processes are turned off).  When they were on, the throughput
> was about 4 Mbps.
>  
> With WEP (encryption) enabled, the highest I got was about 2.7 Mbps,
> when GUI and other daemons/processes were turned off.  (With GUI and
> other daemons/processes running in the background, the throughput was
> about 600 Kbps.)

Few questions.. ;-)

Which Prism2/2.5/3 and which station firmware version are you using?
What about host CPU? Did you use host-based encryption and/or
decryption? Which operation mode (Master?) were you using? Which card
was used as the other part of the test and which driver? Have you seen
the other card with good performance when using WEP?

> I believe this is due to the fact that WEP encryption implemented in the
> device driver is used instead of the WEP encryption in PRISM MAC chip.

This can be the case, if the host system has very low-performance CPU.
However, WEP is not very processor intensive at throughputs provided by
IEEE 802.11b. You should also note that the Host AP driver defaults to
hardware-based decryption (and also encryption, if STA firmware is
version 1.4.9 or newer), so hardware WEP performance might also be an
issue. At least some of the older Prism2 cards used to have poor WEP
performance (I have seen results in 2-3 Mbps range when using hardware
WEP).

> Is there a way to improve the throughput of WLAN with WEP enabled?    Do
> you think using a more powerful processor (CPU) will reduce the
> performance gap between open system and WEP?

I have seen near 6 Mbps throughput with WEP, both using hardware
encrypt/decrypt and doing encrypt/decrypt fully in the driver code. So
yes, the throughput you are seeing can certainly be improved. The first
thing would be to find out which component is the real bottleneck. If it
is indeed host CPU, there are two options that could be used to improve
situation. You could either use faster host CPU or try using hardware
WEP by upgrading the wlan card firmware to at least STA f/w 1.4.9.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list