Are there other sources of unresolved symbols?

James B. Hiller jhiller at
Thu Aug 14 20:24:18 EDT 2003

> > I got the CVS snapshot from the CVS site about 2 hours ago (like
> > 11 pm Wed night) and compiled against my self-compiled kernel,
> > linux-2.4.21.  I have the source tree path set correctly in
> > the Makefile, and still get unresolved symbols.  In addition,
> > I completely cleaned out the /lib modules path, and cleaned out
> > the linux source tree (make clean) and did a fresh compilation of
> > everything, and I still get some in hostap_crypt_wep.
> How did you compile and install the Host AP driver (exact list of
> commands)? Did that report any warnings or errors?

Sorry for not having given more precise info.  Was away from
the compilation machine when sent the email.

a.  Compilation and installation of hostap;
b.  Did that report any warnings or errors?

Untar hostap.tar.gz in /usr/local/packages/incoming.

Change KERNEL_PATH in top Makefile from /usr/src/linux to

Issue make pci

Makefile:38:  WARNING:  No kernel PCMCIA support found and PCMCIA path
  is not defined
In file included from driver/modules/hostap.c:21:
/usr/src/linux-2.4.21/include/linux/module.h:15: warning: `_set_ver' redefined
/usr/src/linux-2.4.21/include/linux/modsetver.h:9: warning: this is the location of the previous definition


make install_pci

which yields only one warning, the one from Makefile:38 above.  The
depmod in the Makefile echoes and completes fine.

c.  Which symbols are reported as unresolved?
d.  What is the exact command you used when you got the error?

In the shell script (/etc/rc.d/rc.local):

/sbin/insmod /lib/modules/2.4.21/net/hostap_crypt_wep.o


/lib/modules/2.4.21/net/hostap_crypt_wep.o:  unresolved symbol hostap_register_crypto_ops_Rsmp_a6d832d1
/lib/modules/2.4.21/net/hostap_crypt_wep.o:  unresolved symbol hostap_unregister_crypto_ops_Rsmp_723f9bd0

f.  Which hardware model?


Note that I was not using modprobe to load these, but rather insmod
(remember, no expert at kernel modules).  Also note that my rc.local
script does in fact include two subsequent insmods for the other two
hostap modules produced, but these do not generate any errors (granted,
however, that I should be doing

modprobe /lib/modules/2.4.21/net/hostap

in the rc.local script, if I undertand you correctly; and I will now
make that change).


More information about the HostAP mailing list