Are there other sources of unresolved symbols?

Jouni Malinen jkmaline at cc.hut.fi
Thu Aug 14 01:13:38 EDT 2003


On Thu, Aug 14, 2003 at 12:45:06AM -0400, James B. Hiller wrote:

> I got the CVS snapshot from the CVS site about 2 hours ago (like
> 11 pm Wed night) and compiled against my self-compiled kernel,
> linux-2.4.21.  I have the source tree path set correctly in
> the Makefile, and still get unresolved symbols.  In addition,
> I completely cleaned out the /lib modules path, and cleaned out
> the linux source tree (make clean) and did a fresh compilation of
> everything, and I still get some in hostap_crypt_wep.

How did you compile and install the Host AP driver (exact list of
commands)? Did that report any warnings or errors?

> Can anyone tell me what else I might do to get rid of these, or
> should I not care?  When the kernel boots and I invoke iwconfig
> in an init script, I get them.  When I insert them manually
> with insmod (which is all I'm doing in the init script), I don't
> get them.

Which symbols are reported as unresolved? What is the exact command you
used when you got the error? Which hw model (pci/cs/plx) are you using?
If cs, you should not be loading the modules yourself. If pci/plx you
should be using modprobe to load the module so that all the dependencies
(hostap.o) gets loaded properly. hostap_crypt_wep.o is loaded only when
needed; or to be more exact, Host AP driver asks it to be loaded if your
kernel module loader is working correctly.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list