Still no ap action going on here :( help please.

Nerdboy nerdboy at rocksolidnetworks.com
Fri Dec 13 03:09:36 EST 2002


Manjunathan,
	Hi. I tried blah and any on both linux and windows workstations. I belive the 
any essid is a reserved/key word which tells the software/device to just use 
any essid it can find. wep is definetly disabled (iwconfig says so, and I 
havnt made any keys for it...). 
	I went to the LUG meeting tonite, we have an ap runnig there, so I brought my 
laptop, and 3 hard drives (they pull out easily). I started the laptop with 
the windows drive first. It promptly prompted me with a message telling me 
its connected to the AP... I pulled up the proxim software, and found I had 
associated, and an excelent signal strength. Woo Hoo! 
	I swapped out the hard disk, and tried the hostap (in Infrastructer/managed 
mode) no luck :( I tried the orinoco_cs module too... no luck! I tried them 
both using the previous kernel/modules (2.4.19-rc3)... no luck. 
	I did notice that when I put it in managed mode, I got some odd errors!
wlan0: hfa384x_cmd: entry still in list? (entry=c10b1220, type=0, res=0)
wlan0: hfa384x_cmd: command was not completed (res=0, entry=c10b1220, type=0, 
cmd=0x0002, param0=0x0000)
wlan0: MAC port 0 reseting failed
I dont know what that means... but it dosnt look good!
I also noticed this:
hostap_cs: index 0x01: Vcc 5.0, irq 3, io 0x0100-0x013f
The card is suposed to be a 3.3 volt card (but my laptop doesnt support that I 
guess...) however it does work in windows (yeah... I hate it when people say 
that too!)

I can try setting the ssid to Super-wlan, but I just dont think its going to 
make any difference. it shouldnt be any better than blah.

Once again, I have not seen this card work at all in linux, no matter wether I 
use hostap, orinoco, ad-hoc, infrastrucure/managed or master modes. I think 
Ive tried every possible combination, used 4 different kernel sources 
(2.4.18, 2.4.19,2.4.19-rc3, 2.4.20)
What can I possibly be doing wrong!

Jamie




 	
 On Thursday 12 December 2002 08:35 pm, Manjunathan PY wrote:
: Hi,
:
:
:  I still feel that every things is fine with the configuration, except that
: you are using    essid "blah" on HostAP and "Any" on Windows clients, this
: may not work. So do something like as given below!
:  Check if you have disabled the wep security on the Windows laptops.
:
:  Also verify if your configuration on Hostap i.e Linux box is as shown
: below
:
: --------------------------------Hostap
: Configuration--------------------------------------
: IEEE 802.11-b  ESSID:"Super-Wlan"
:           Mode:Master  Frequency:2.422GHz  Access Point: 00:60:B3:6F:63:CC
:           Bit Rate:11Mb/s   Tx-Power:-6 dBm   Sensitivity=1/3
:           Retry min limit:8   RTS thr:off   Fragment thr:off
:           Encryption key:off
:           Power Management:off
:           Link Quality:0  Signal level:0  Noise level:0
:           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
:           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
:
: ---------------------------------------------------------------------------
:- ----------------------
:
:
:
: --------------------------------Client configuration running on Windows
: laptops-----------------------
:
: IEEE 802.11-b  ESSID:"Super-Wlan"
:           Mode:Managed  Frequency:2.422GHz  Access Point: 44:44:44:44:44:44
:           Bit Rate:11Mb/s   Tx-Power:-6 dBm   Sensitivity=1/3
:           Retry min limit:8   RTS thr:off   Fragment thr:off
:           Encryption key:off
:           Power Management:off
:           Link Quality:0  Signal level:0  Noise level:0
:           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
:           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
:
:
:
: With WEP security options =  disabled, also encryption key is off (open
: authentication)
:
: ---------------------------------------------------------------------------
:- --------------------------------------------------
:
: Note that ESSID in both the hostap and client are same. Make sure that
: essid field is same in hostap and on two clients. This is very important
: for associate (in open authentication method).
:
: I think this should solve ur problem!
:
: Cheers,
:
: Manjunathan PY




More information about the HostAP mailing list