[BUG] - Realtek wifi do not work with version 2.3 or 2.4 but does work on 1.0

Jouni Malinen j at w1.fi
Mon Mar 23 15:32:54 EDT 2015


On Mon, Mar 23, 2015 at 07:09:54PM +0000, John wrote:
> > It should be possible to set the driver interface to "nl80211,wext" to
> 
> > make wpa_supplicant first try nl80211 and if that fails, then fall back
> > to wext.
> 
> Wait, I think I understand.  Are you suggesting that I use "-Dnl80211,wext" on my invocation of wpa_supplicant?  Again, I think I would need to modify the systemd .service file with this info, no?

Yes, if you want to have a single wpa_supplicant binary that works with
both nl80211 and WEXT drivers without having to specifically configure
which driver interface to use, this would likely be the most convenient
way of doing that. I'm not very familiar with systems configuration, but
if the .service file describes how wpa_supplicant gets started, then
yes, that would likely be the place to do this.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list