Hostapd and MCS rates

Krishna Chaitanya chaitanya.mgit at gmail.com
Mon Jun 22 04:46:52 EDT 2015


On Mon, Jun 22, 2015 at 2:06 PM, Mathieu Slabbinck
<matty.slabbinck at gmail.com> wrote:
> On Mon, Jun 22, 2015 at 10:28 AM, Krishna Chaitanya
> <chaitanya.mgit at gmail.com> wrote:
>> On Mon, Jun 22, 2015 at 1:55 PM, Mathieu Slabbinck
>> <matty.slabbinck at gmail.com> wrote:
>>> Done that now, but no immediate change is visible.
>>> But before digging any deeper, can someone post me the correct hostapd
>>> config to be able to have for example 72.2 MBit/s (mcs index 7) in n
>>> mode?
>>> Just to prevent bad config on my side.
>>
>> The below config should be fine in 2.4GHz, 11n, 20MHz, SGI enabled
>> interface=wlan0
>> ssid=test
>> hw_mode=g
>> channel=6
>> beacon_int=100
>> dtim_period=2
>> max_num_sta=255
>> rts_threshold=2347
>> fragm_threshold=2346
>> macaddr_acl=0
>> auth_algs=3
>> ignore_broadcast_ssid=0
>> wmm_enabled=1
>> ieee80211n=1
>> ht_capab=[SHORT-GI-20]
>
> Thanks.
>
> That config together with iw cmd: iw dev wlan0 set bitrates ht-mcs-2.4 7 sgi-2.4
> doesn't seem to change anything. captured packets are 1, 24 or
> 54MBit/s but no mcs rates.
ath9k has IEEE80211_HW_HAS_RATE_CONTROL enabled by default, so
mac80211 simply conveys the rate mask to ath9k and it sends to FW as
the rate control is implemented in FW. So from Host side i don't think
we can do much
except to confirm the mask information is passed down to the driver
(some debugs in ath9k driver: ath9k_htc_set_bitrate_mask).

BTW does your dmesg show any errors after setting the rates through iw?


More information about the HostAP mailing list