wpasupplicant and WEP (more info)

Jouni Malinen j at w1.fi
Sun Jan 4 09:13:18 EST 2015


On Sun, Jan 04, 2015 at 02:12:18PM +0100, Erich Titl wrote:
> OK, I have another card, e.g. ath5k which behaves exactly the same way.

Strange.. I would have assumed this would work with ath5k. I haven't
tested that in a long while, though.

> Sounds like bad luck. Is WEP done in the driver itself?

WEP with a static key is handled by driver/firmware/WLAN hardware, i.e.,
user space is just configuring the key to the driver and that's about
it.

> Do you have an idea why the dhcp request passes WEP but the dhcp reply
> does not?

Not really. I can only assume that either there is some mismatch in the
network configuration or there are some driver issues involved. I'm
testing both unicast and broadcast Data delivery with WEP as part of the
automated regression tests with mac80211_hwsim and that works fine and I
don't remember any recent issues in this area either.

Wireless sniffer trace showing all the frames exchanged between the AP
and the station would likely make it clear where the issue is.

> Is wpa_supplicant just a front end to iw, e.g. the driver in the case of
> WEP?

No, wpa_supplicant does not use iw, but the connection setup for WEP
with static keys is very simple and both iw and wpa_supplicant should
behave identically in this. In other words, you can easily check whether
the issue is specific to wpa_supplicant (which I'd assume it is not) by
testing with iw.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list