Question on scan results from Aruba AP

Ben Greear greearb at candelatech.com
Sat Feb 21 11:15:07 EST 2015



On 02/21/2015 02:06 AM, Jouni Malinen wrote:
> On Thu, Feb 12, 2015 at 03:36:51PM -0800, Ben Greear wrote:
>> Someone was connecting our ath10k station to their AP, and it seems the
>> station only does '/n', even though AP is supposed to be doing /AC.
>>
>> The AP is an Aruba IAT-225, and it's scan results are below.
>
> How is this AP supposed to be configured as far as channel(s) are
> concerned? And how did you check whether VHT is used?

I don't know anything else about how the AP was configured
at this point.

My station could associate with it, but it showed 'vht capabilities' as disabled
('ht' capabilities were there).


>> I am guessing the problem is in the 'VHT Operation' section?
>>
>> Or, does this scan actually look valid (and so problem may be on
>> the station?)
>
> Well.. It depends on what this is trying to do.
>
>> 	HT operation:
>> 		 * primary channel: 40
>> 		 * secondary channel offset: no secondary
>
> This seems to imply that the AP has only 20 MHz channel in use.
>
>> 	VHT operation:
>> 		 * channel width: 0 (20 or 40 MHz)
>> 		 * center freq segment 1: 0
>> 		 * center freq segment 2: 0
>
> And this would also agree with that..
>
> As an example, the mac80211_hwsim test case ap_vht_20 uses similar
> configuration and results in this type of scan results. mac80211_hwsim
> enables VHT in such configuration (VHT Capabilities is present in
> Association Request frame).

Does this part look correct (from previous email)?

  * VHT basic MCS set: 0x0000


Thanks,
Ben

-- 
Ben Greear <greearb at candelatech.com>
Candela Technologies Inc  http://www.candelatech.com


More information about the HostAP mailing list