wpa_supplicant: Experimenting with wifi_display

Jouni Malinen j at w1.fi
Thu Feb 6 09:08:39 EST 2014


On Tue, Feb 04, 2014 at 05:05:57PM +0000, Mike Auty wrote:
> I've recently been trying out the wifi_display support in wpa_supplicant
> (I just tested this with wpa_supplicant-2.1).  I realize from the lack
> of documentation that this is still under development and not at all
> ready for bug posts or similar, but I thought I'd try it and see where I
> could get to in its current state.

As far as I know, it works fine and is used in large number of deployed
devices.

> There appear to be a number of calls that don't sufficiently check the
> validity of the variables they're handed, and attempting to use
> openwfd_p2pd I end up segfaulting in p2p_set_wfd_dev_info in p2p.c.
> Tracing the call back (full bt attached for those that are interested) I
> get to wifi_display_update_wfd_ie in wifi_display.c which had global
> with p2p as null (global from gdb attached too).

The only way I was able to reproduce this was by manually forcing P2P to
be disabled first. Obviously, wpa_supplicant should not hit segfault in
such a case and I'll fix that, but anyway, I'm assuming the main reason
for the issues you are seeing is in P2P not being enabled in the first
place. Which driver are you using?

> The list of commands openwfd uses are as follows:
> 
> GET wifi_display
> SET ap_scan 1

I'm not sure what these commands are trying to achieve..

> SET device_name some-random-name
> SET device_type 1-0050F204-1
> SET wifi_display 1

.. but these are fine.

> That last one triggers the segfault, presumably because no p2p
> connection has been setup already?  My knowledge of Wifi Direct is
> limited though, so that's about as far as i can get.

You don't need P2P connection for this, but you do need the P2P module
to be initialized and that will happen only if the driver supports P2P.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list