Hostap and openssl version.

Jouni Malinen j at w1.fi
Tue Oct 22 09:05:38 EDT 2013


On Wed, Oct 16, 2013 at 09:11:45AM -0700, Anand Moon wrote:
> While compiling hostapd for WPS support it need to include openssl and link openssl library.

There is no such requirement. Other crypto libraries or the internal
implementation could be used as well.

> Which version of openssl will be compatible for hostapd-2.0 ?

I haven't tested all combinations, but I'd expect any release 0.9.8 or
newer to work.

> Do we need to apply the patch present in hostapd-2.0/patches to openssl in order to make WPS work correctly ?

No. Those are only for EAP-FAST with OpenSSL versions that are older
than 1.0.0.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list