bgscan simple not always working

Matthew Dalton msdalton at gmail.com
Tue Dec 3 01:10:27 EST 2013


That's "dropping off the wifi" not "dropping of".

Matt



On Tue, Dec 3, 2013 at 5:08 PM, Matthew Dalton <msdalton at gmail.com> wrote:

> Hi Holger,
>
> Thanks for the reply.
>
> I'll try the git HEAD as a last resort, but for now I'm trying to figure
> out what's wrong while keeping the configuration constant.
>
> Since my original post I have managed to get roaming working... but I did
> it by putting system("wpa_cli roam bssid") calls in my code. Clearly
> bgscan-controlled roaming could work (ie. there's nothing in my network
> setup to prevent it), but it doesn't seem to work for me.
>
> Anyway, I'm having much bigger issues now, with clients randomly dropping
> of the wifi for no apparent reason. Putting "-ddddddt" in the command-line
> for wpa_supplicant doesn't produce anything useful. Mostly a spamming of
> STATUS and SCAN_RESULTS and the odd ROAM due to my forced roaming system
> calls. Nothing to indicate that the network was absent for a few minutes. I
> suspect the wifi access points are to blame for this, that their
> mesh/bridge implementation is flaky, but I'm still trying to find real
> proof that that's the case. If anyone knows where in the wpa_supplicant
> source code such errors may be detectable, please let me know, even if it's
> a reference to the current git HEAD of wpa_supplicant.
>
> Cheers,
> Matt
>
>
>
> On Mon, Dec 2, 2013 at 9:37 PM, Holger Schurig <holgerschurig at gmail.com>wrote:
>
>> Hi Matt,
>>
>> most programmers here in this list use wpa_supplicant from the current
>> git HEAD. So if you can compile that, replicate your problem and
>> provide a log file, this would be helpful.
>>
>> You can git clone the hostapd project, then compile only
>> wpa_supplicant. Then you can do "ifdown wlan0", and start the locally
>> compiled wpa_supplicant: "./wpa_supplicant -s -i wlan0 -D nl80211 -C
>> /etc/wpa_supplicant.conf -d". That way your Debian packaged
>> wpa_supplicant won't be clobbered for the first test(s).
>> wpa_supplicant automatically brings up the interface (equivalent of
>> "ifconfig up", not setting IP adresses etc). But that is good enought
>> for roaming tests.
>>
>> Also note that wpa_cli has a command "roam <bssid>" as a debugging
>> aid. So you can try to roam manually to the AP in question, and then
>> observe the debug output.
>>
>> Maybe the AP is simply sending beacons that he needs encryption, you
>> wpa_supplicant.conf file doesn't contain any encryption, so APs with
>> demand that are ignored for roaming decisions.
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.shmoo.com/pipermail/hostap/attachments/20131203/575d977c/attachment.htm>


More information about the HostAP mailing list