Is wpasupplicant 0.7.3-6 compatible with 5Ghz band steering?

Jouni Malinen j at w1.fi
Sat Mar 31 13:43:42 EDT 2012


On Sat, Mar 31, 2012 at 08:10:57AM -0700, Marc MERLIN wrote:
> My company recently turned on band steering to redirect 5Ghz capable clients
> from 2.4Ghz to 5Ghz.
> 
> This is causing no end of trouble for my 5300AGN linux client.

It is a bit unfortunate that some AP vendors have introduced this type
of proprietary functionality on their own without going through proper
standardization and just hoping that stations behave in the way that
works with their not necessarily even publicly documented mechanism..

> I'm running 3.2.8 kernel with iwlwifi-5000-5.ucode and wpasupplicant 0.7.3-6 

I would suggest testing with a newer wpa_supplicant snapshot and nl80211
driver interface. It's likely to handle this type of networks quite a
bit better.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list