hostapd with WPS/PBC setup has problems with Win7 clients

Mustafa Yücel yuecel at tik.ee.ethz.ch
Tue Feb 28 12:16:59 EST 2012


On 02/18/2012 10:58 AM, Jouni Malinen wrote:
> On Tue, Feb 14, 2012 at 08:22:34PM +0100, Mustafa Yücel wrote:
>> I try since a few days to get the push-button-connect feature working,
>> only with partial success. the PBC setup works with my Android table as
>> client, but I have troubles with Win7 clients (tested with a up-to-date
>> Win7 handheld and a up-to-date Win7 laptop), I get the whole time this
>> window:
>> http://www.dlink.cc/wp-content/uploads/2010/08/win7-wireless5.jpg
>> instead of this:
>> http://www.windowsnetworking.com/img/upl/image0011300383261594.jpg
> 
>> I tested as far the following versions:
>>
>> a) release 0.7.3
>> b) hostap.git 83fa07226debc2f7082b6ccd62dbb1cd47c30472
>> c) hostap-1.git c9522b94c77733fcac8ebaed4ca71d2e0365b1cf
> 
> That hostap.git snapshot is quite old. I would suggest testing with the
> current snapshot. That seems to result in the "You can also connect by
> pushing the button on the router." dialog with the configuration file
> you used and couple of Windows 7 devices I tested with. Then again, so
> did the (c) (i.e., hostap_1_0_rc2) version for that matter. I'm testing
> with OpenWRT/ath9k, but if you have WPS working in general, this should
> not really be driver specific.

Hi Jouni,

can you send me the hostapd.conf file, the hostapd version, and
hostapd's defconfig you used successfully with the Win7 devices? I use
here different drivers (wl12xx_sdio/nl80211) but its not working even
with a recent version like hostap_1_0_rc2. I will try here the same
config set you have...

Thanks,
Musti


More information about the HostAP mailing list