hostapd-1-rc3: Wireless lags and unstable connection

Valeriy Kucherenko darkside_ua at ukr.net
Thu Apr 26 06:04:41 EDT 2012



Hi.

I'm currently using hostapd-1-rc3 and have noticed periodic connection lags that causes problems when, for example, playing online games or listening to streaming music.
Here is a part of ping output (from AP to wireless client) when the lag appears:

64 bytes from 192.168.0.5: icmp_req=869 ttl=128 time=2.38 ms
64 bytes from 192.168.0.5: icmp_req=870 ttl=128 time=6.79 ms
64 bytes from 192.168.0.5: icmp_req=871 ttl=128 time=3059 ms  <-- here it is
64 bytes from 192.168.0.5: icmp_req=872 ttl=128 time=2053 ms
64 bytes from 192.168.0.5: icmp_req=873 ttl=128 time=1046 ms
64 bytes from 192.168.0.5: icmp_req=874 ttl=128 time=38.9 ms
64 bytes from 192.168.0.5: icmp_req=875 ttl=128 time=4.51 ms
64 bytes from 192.168.0.5: icmp_req=876 ttl=128 time=5.90 ms

These lags occurs approximately each 10 minutes and I'm guess that the problem in WPA group rekeing routine (I have set wpa_group_rekey=600 in my config).

I'll try to provide as more info on this problem as I can, so here it is:

hostapd build ".config" file with my comments on some options - http://pastebin.com/0j5f6f9D
hostapd.conf - http://pastebin.com/9vwiDCbB
hostapd debug output - http://pastebin.com/mCnB226v

AP OS details:
Linux 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 17:34:21 UTC 2012 i686 i686 i386 GNU/Linux without any compat-wireless compiled
Load average: 0.01, 0.03, 0.05
Wireless card: AR922X Wireless Network Adapter (TP-Link TL-WN851N)

Client OS details:
Dell XPS-L501X, Windows 7 Pro x64
Wireless card: Intel Centrino Advanced-N 6200 AGN
Drivers: Intel PROSet/Wireless 13.5.0.6


More information about the HostAP mailing list