wireless network stopped working after upgrading linux kernel to version 2.6.34

Denis Laroche dlaroche7 at gmail.com
Tue Jul 20 09:03:31 EDT 2010


Hi all,

I had wpa_supplicant working perfectly on Linux, but it stopped working when
I recently upgraded the kernel to version 2.6.34. I'm using the wl driver
from Broadcom; I downloaded the latest distribution tar file from Broadcom
(as well as a patch for kernel >=2.6.33) and rebuilt it.

The version of wpa_supplicant is 0.7.2, and I'm using the same
wpa_supplicant.conf that was working before.

It might be an issue with the driver, because I see an ioctl error when
running wpa_supplicant with tracing.

Below is a transcript of running wpa_supplicant interactively with tracing.

Thanks in advance for any help.

====================================================

*wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -Dwext -ieth1 -d *

Initializing interface 'eth1' conf '/etc/wpa_supplicant/wpa_supplicant.conf'
driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' ->
'/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='wheel'
ap_scan=1
Priority group 5
   id=0 ssid='questar'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=19 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
netlink: Operstate: linkmode=1, operstate=5
Own MAC address: 00:26:5e:5d:12:03
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
ctrl_interface_group=10 (from group name 'wheel')
Added interface eth1
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
Wireless event: cmd=0x8b1a len=48
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
Trying to get current scan results first without requesting a new scan to
speed up initial association
ioctl[SIOCGIWSCAN]: Invalid argument
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
Scan requested (ret=0) - scan timeout 5 seconds
EAPOL: disable timer tick
EAPOL: Supplicant port status: Unauthorized
Scan timeout - try to get results
ioctl[SIOCGIWSCAN]: Invalid argument
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Starting AP scan for wildcard SSID
Scan requested (ret=0) - scan timeout 5 seconds
Scan timeout - try to get results
ioctl[SIOCGIWSCAN]: Invalid argument
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
Starting AP scan for wildcard SSID
Scan requested (ret=0) - scan timeout 5 seconds
Scan timeout - try to get results
ioctl[SIOCGIWSCAN]: Invalid argument
Failed to get scan results
Failed to get scan results - try scanning again
Setting scan request: 1 sec 0 usec
^CCTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth1
No keys have been configured - skip key clearing
State: SCANNING -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
netlink: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portValid=0
EAPOL: Supplicant port status: Unauthorized
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
netlink: Operstate: linkmode=0, operstate=6
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20100720/bef65763/attachment-0001.htm 


More information about the HostAP mailing list