EAPOL Key Timeout 1/4

Daniel Rönnqvist kdronnqvist at gmail.com
Wed Oct 21 03:01:07 EDT 2009


Hi again,

when running hostapd (nl80211/bcm4306 on a ppc mac) with kernel 2.6.30
it works kind of ok. One of my two laptops at home can connect and
that's the one usually having better connection to any AP (stronger
signal). The other one can connect but will get disconnected after a
few minutes. Both are WinXP.

When running with kernel 2.6.31 it wont work at all, the EAPOL keys
are only rarely seen going out on wlan0 when I use tshark. If they go
out they are answered by the client (verified with wireshark on
client) but the response is never seen on the AP side. This was my
problem when I first posted this issue.

With and 2.6.32-rc I get kernel scheduler errors in my dmesg and soon
after starting to send traffic over the wlan the machine crashes, it's
an RC after all.

So going back to 2.6.30 kind of solves my problem, except for one of
my XP machines but I can't really blame hostapd for that, can I? ;)

Just thought I would let you know if there's anyone having the same problem.

BR,
Daniel



Den 15 oktober 2009 11.18 skrev Daniel Rönnqvist <kdronnqvist at gmail.com>:
> 2009/10/14 Jouni Malinen <j at w1.fi>:
>> On Wed, Oct 14, 2009 at 09:11:00AM +0200, Daniel Rönnqvist wrote:
>>
>>> * Is hostapd from git supposed to work with nl80211 (with a bcm4306 rev3)?
>>
>> I don't know about bcm4306, but at least the current snapshot of hostapd
>> seems to be working fine with the ath9k driver.
>>
>>> * What does "deauthenticated due to local death" mean?
>>
>> It means that hostapd requested a station to be deauthenticated (in this
>> case, I would assume it happened due to the WPA 4-way handshake timing
>> out).
>>
>>> * The only messages i see with tshark during the authentication
>>> process is "EAPOL Key" and some "LLC" messages coming from the client
>>> MAC. The hostapd log says EAPOL Key Timeout on handshake 1/4. Is this
>>> enough to guess what ballpark my problem is in?
>>
>> Have you verified that your client is receiving the EAPOL-Key message
>> 1/4 and replying with 2/4?
>>
>> --
>> Jouni Malinen                                            PGP id EFC895FA
>
> I see EAPOL key coming in on the client and it is answering to the
> correct MAC address, but the AP is always just saying EAPOL key
> timeout on 1/4. On the AP side i do "tshark -i wlan0" and see the
> EAPOL key going out but nothing is coming back. However, I am reading
> up on the subject because as of now I must admit that I do not know
> how this works. I should be able to give a better description of my
> problem in a week or so (after becoming junior guru of wifi) :) I did
> get this setup to work before but after upgrading to Debian testing it
> just wont.
>
> BR,
> Daniel
>


More information about the HostAP mailing list