Hostapd Multicast Group Key Issue on PowerPC vs x86

Damon Southworth damon at cloudydaze.homeip.net
Tue May 5 08:46:28 EDT 2009


More information around the problem....

Damon Southworth wrote:
>> This could have something to do with the byte order of the RSC in the
>> initial group keys. Are you using WPA or WPA2? TKIP or CCMP?
> 
> Hostapd is configured for WPA (wpa=1). I have left the selection of
> TKIP/CCMP unspecified (default). The client can also select either. In
> this configuration I suppose I would expect it to select TKIP which does
> appear to be the case.

I have now also tried wpa2 (wpa=2) with only CCMP enabled. I had to
disable wme (as described in bug 215) in order to get this to work.

The symptoms are still the same with this configuration. Multicast
messages only come through after the first group re-key when the access
point is on the PowerPC platform.

Also....

In order to try and check if this is purely related to a setup using the
madwifi drivers I wanted to try a different kernel driver/ MAC layer
however I have not yet found another working combination.

I have access to Atheros and Prism54 (ISL3890 FullMAC) MiniPCI cards. So
far the Ath5k drivers using the nl80211 interface do not yet allow
master mode by default. If I override this in the driver I can bring the
card up but I can't detect the access point in any stations scan list.

The Prism54 drivers no longer work with hostapd. The new p54 drivers
using the nl80211 interface bring the card up but again I can't detect
the access point in any stations scan list.

Damon.


More information about the HostAP mailing list