Hostapd Multicast Group Key Issue on PowerPC vs x86

Jouni Malinen j at w1.fi
Sat May 2 04:03:10 EDT 2009


On Fri, May 01, 2009 at 11:15:50PM +0100, Damon Southworth wrote:

> The system is PowerPC based and to try and identify which component was
> causing the problem I created the same setup on an x86 platform.
> Surprisingly this x86 set-up worked without problem.
> 
> The problem is related to the group key as when the connection is
> authenticated multicast messages come straight through on the x86 box
> but do not come through on the PowerPC box until a group key re-key
> takes place which is 600 seconds by default. A dirty workaround would be
> to drop the group re-key time but there is still a delay and the side
> affect of constant group re-keying.

This could have something to do with the byte order of the RSC in the
initial group keys. Are you using WPA or WPA2? TKIP or CCMP?

> I can supply config files/debug logs if the problem rings any bells with
> anyone although both x86 and powerpc logs looking identical (except for
> the encryption) to me so far.

I would like to see both the configuration and detailed debug logs to
see whether there is anything visible there as far as configuring the
GTK is concerned.

> Recent versions of the main components were used:
> 	Hostapd 0.6.9
> 	Wpasupplicant 0.6.4
> 	madwifi 0.9.4
> 	kernel 2.6.28.8

Is the same kernel/driver used for both the AP and client? Is PowerPC
used only in the AP and client is x86?

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list