Can't obtain DHCP address

Dmitry Baryshev ksquirrel.iv at gmail.com
Mon Feb 9 14:09:37 EST 2009


2009/2/9, Dmitry Baryshev <ksquirrel.iv at gmail.com>:
> 2009/2/8, Jouni Malinen <j at w1.fi>:
>
> > On Thu, Feb 05, 2009 at 05:55:26PM -0500, Dmitry Baryshev wrote:
>  >
>  >  > I have a D-Link WBR-2310 wireless router, it is configured to use
>  >  > WPA+TKIP+"Personal". Before I should say that WEP security mode works
>  >  > fine, DHCP works well, but WPA doesn't. I configure router to have
>  >  > SSID="dima" and password "12345678". I have the following config for
>  >  > wpa_supplicant:
>  >
>  >
>  > Which WLAN card and driver are you using in the client?
>  >
>
>
> Don't know exactly, but wifi is served by "vntwusb" kernel module.
>
>
>  >  > # wpa_supplicant -Dwext -B -u -c ~/.config/supplicant.conf -i eth1
>  >  > -P/tmp/wpa_supplicant/pid
>  >
>  >
>  > Could you please run this in foreground and with debugging enabled
>  >  (replace -B with -dd on the command line) and send the debug output?
>  >
>
>
> I pasted log here:
>
>  http://pastebin.com/f10d96825
>
>  config file for wpa_supplicant now is:
>
>
>  ctrl_interface=/tmp/wpa_supplicant
>
>  network={
>         ssid="dima"
>         key_mgmt=WPA-PSK
>
>         #psk=251bdf8dae035c415fa63a77bd568be598545e05e7dd132bde0e136cb5f341d1
>         psk="12345678"
>
> }
>
>
>  >
>  >  > My kernel is 2.6.26, wpa_supplicant is 0.5.10. Static IP seems to work
>  >  > for this security type, but DHCP doesn't. Why? Thanks.
>  >
>  >
>  > What do you mean with static IP working? Can you use the connection fine
>  >  just by setting the IP address manually? Have you checked whether the
>  >  client is able to receive broadcast packets? I would assume your DHCP
>  >  server is replying with broadcast frames and the client may fail to
>  >  receive them.
>  >
>  >
>
>
> It seems that ifconfig eth1 192.168.0.103 can assign IP address, but
>  the interface still doesn't work, "route add default gw 192.168.0.1
>  dev eth1" says that network is unreachable. My DHCP client is udhcpc
>  from busybox 1.7.2 (udhcpc from Debian Lenny doesn't work too). By the
>  way, DHCP from the same router but for Ethernet card works fine.
>
>  I strace-d udhcpc, and it seems that udhcpc sends DHCP broadcast
>  packets, but cannot recieve any answer. (With WEP security type
>  configured on router, DHCP works!).
>
>  Thanks.
>
>
>  --
>


Wireshark log in wireshark/libpcap format attatched.

-- 
Regards, Krasu.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: wireshark.log
Type: application/octet-stream
Size: 5250 bytes
Desc: not available
Url : http://lists.shmoo.com/pipermail/hostap/attachments/20090209/274fcb5f/attachment-0001.obj 


More information about the HostAP mailing list