trying to set up open access point with hostapd on ath5k

GregNorc gregnorc at gmail.com
Fri Aug 28 11:30:48 EDT 2009


So, I'm trying to set up an Eee 4G as a wireless ap, using hostapd 0.6.9

It's running FC11 (kernel is 2.6.29-167).

I installed the appropriate kernel-devel, updated libnl, crda etc.
Everything should be working... theoretically.

However when I run hostapd I get this error:

[root at localhost songwhale]# hostapd -dd /etc/hostapd.conf
Configuration file: /etc/hostapd.conf
ctrl_interface_group=0
Failed to set interface wlan0 to master mode.
nl80211 driver initialization failed.
wlan0: Unable to setup interface.
rmdir[ctrl_interface]: No such file or directory
ELOOP: remaining socket: sock=5 eloop_data=0x95ca830 user_data=(nil)
handler=0x807ad60


I had thought maybe network manager and or the dhcp daemon was
interfering. I stopped both (/etc/init.d/NetworkManager stop &&
/etc/init.d/dhcpd stop) and tried running hostapd again, and got the
same error. I tried also bringing down the wlan0 interface with
ifconfig, and still got the error.



More information about the HostAP mailing list