Drop dependency on pcsc-lite

Reinhard Tartler siretart at tauware.de
Wed Jul 23 05:17:18 EDT 2008

Hi Jouni, hi wpasupplicant developers,

cf http://thread.gmane.org/gmane.linux.ubuntu.devel/25861 for technical
background of this request.

In ubuntu, we are currently considering the pcsc-lite support of
wpa_supplicant. We currently do not support the pcsc-lite package in the
'main' component of ubuntu, and are pondering a way of avoiding that. In
other words, we look for some way for enabling smartcard support without
having the pcsc-lite package available at build time.

A technical solution would be to include use dlopen() the
libpcsclite.so.1 library. Now I would like to ask you if you think this
approach feasible/acceptable and would consider an according patch to that.

Reinhard Tartler, KeyID 945348A4

More information about the HostAP mailing list