Does wpa_supplicant work on Win98?

Jouni Malinen j at w1.fi
Thu Jul 10 21:16:25 EDT 2008


On Wed, Jul 09, 2008 at 10:34:38PM -0400, void at no.spam.com void at no.spam.com wrote:

> OK, I just downloaded wpa_supplicant versions 0.5.10,  0.4.11, and 0.3.11.
> Got an error about PACKET.DLL, so I downloaded WinPcap 3.1 (latest version
> that supports 98) to solve that problem.  I also downloaded
> http://w1.fi/wpa_supplicant/qt4/wpa_gui-qt433-windows-dll.zip.
> 
> When I try to run wpa_gui.exe for version 0.5.10, I get a "A required .DLL
> file, QT3SUPPORT4.DLL, was not found" error.  That
> wpa_gui-qt433-windows-dll.zip file only includes mingwm10.dll, QtCore4.dll,
> and QtGui4.dll.  Where can I get QT3SUPPORT4.DLL?

Qt3Support4.dll is part of Qt4 libraries and is likely available
somewhere in the internet ;-). Anyway, I would suggest testing wpa_gui
from 0.6.3 since the latest version should not need Qt3 support anymore.

> Also, when I try to run wpa_supplicant.exe version 0.5.10, I get a "The
> WPA_SUPPLICANT.EXE file is linked to missing export
> ADVAPI32.DLL:ConvertStringSecurityDescriptorToSecurityDescriptorA." error
> message.  Is it calling an API that is not available in 98?

Sounds like that. This may end up being somewhat more difficult to
resolve.. I would assume this is coming from WMI code and it might be
possible to disable that for a test and rely on polling the driver for
association data.

-- 
Jouni Malinen                                            PGP id EFC895FA


More information about the HostAP mailing list