Debian Sid, madwifi and hostapd

MICHEL Benoît benoitm at exakis.com
Fri Aug 22 11:09:08 EDT 2008


Hi all,

I'm trying to set up my debian box (sid, kernel 2.6.26, hostapd 0.5.10)
as a wifi ap using a sweex LW051 card with the madwifi driver.


Bridging is enabled in my kernel.

Here is my configuration files:

1) /etc/network/interfaces:
auto lo
iface lo inet loopback

# Internet
auto eth1
iface eth1 inet dhcp

# Bridge pour internet
iface ath0 inet static
        wireless-mode master
        wireless-channel 9


auto bridge
iface bridge inet static
        address 192.168.0.254
        netmask 255.255.255.0
        broadcast 192.168.0.255
        bridge_ports eth0 ath0
        pre-up iptables-restore < /etc/iptables.up.rules-bridge

2) I added this line to /etc/modprobe.d/madwifi to create the vap in master mode :
options ath_pci autocreate=ap

3) /etc/hostapd/hostapd.conf

interface=ath0
bridge=bridge
driver=madwifi

logger_syslog=-1
logger_syslog_level=1
logger_stdout=-1
logger_stdout_level=2

debug=2
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=BOUCS
hw_mode=g
macaddr_acl=0
accept_mac_file=/etc/hostapd/hostapd.accept
deny_mac_file=/etc/hostapd/hostapd.deny
auth_algs=1
eap_server=0
wpa=3

wpa_passphrase=ceciestmaclefdelamortquitue
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP




Here is the log file (-dd option):


Configuration file: /etc/hostapd/hostapd.conf
ctrl_interface_group=0
Configure bridge bridge for EAPOL traffic.
madwifi_set_iface_flags: dev_up=0
madwifi_set_privacy: enabled=0
BSS count 1, BSSID mask ff:ff:ff:ff:ff:ff (0 bits)
SIOCGIWRANGE: WE(compiled)=22 WE(source)=18 enc_capa=0xf
ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
Deauthenticate all stations
madwifi_set_privacy: enabled=0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=0
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=1
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=2
madwifi_del_key: addr=00:00:00:00:00:00 key_idx=3
Using interface ath0 with hwaddr 00:16:0a:06:e1:d8 and ssid 'BOUCS'
SSID - hexdump_ascii(len=5):
     42 4f 55 43 53                                    BOUCS
PSK (ASCII passphrase) - hexdump_ascii(len=27):
     63 65 63 69 65 73 74 6d 61 63 6c 65 66 64 65 6c   ceciestmaclefdel
     61 6d 6f 72 74 71 75 69 74 75 65                  amortquitue
PSK (from passphrase) - hexdump(len=32): 77 28 e4 bf d9 8d 11 a2 83 20 14 e7 bb 0f 14 7b 9d f9 f5 a3 d6 70 b7 b2 a3 5c c3 5b 36 28 12 9f
madwifi_set_ieee8021x: enabled=1
madwifi_configure_wpa: group key cipher=1
madwifi_configure_wpa: pairwise key ciphers=0x2
madwifi_configure_wpa: key management algorithms=0x2
madwifi_configure_wpa: rsn capabilities=0x0
madwifi_configure_wpa: enable WPA=0x3
ioctl[IEEE80211_IOCTL_SETPARAM]: Invalid argument
set80211param: Failed to set parameter (op 3 arg 5)
ath0: DRIVER Error enabling WPA/802.1X!
IEEE 802.1X initialization failed.
ath0: Unable to setup interface.
l2_packet_receive - recvfrom: Network is down
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
Deauthenticate all stations
rmdir[ctrl_interface]: No such file or directory
madwifi_set_ieee8021x: enabled=0
madwifi_set_iface_flags: dev_up=0


And I find these two lines in my syslog every time I launch hostapd :
ath0: IEEE 802.11 Fetching hardware channel/rate support not supported.
ath0: DRIVER Error enabling WPA/802.1X!

What's wrong ?

Any suggestion are welcome.

Thanks in advance.

Cheers,

Ben


More information about the HostAP mailing list