CTRL-EVENT-DISCONNECTED on high traffic with hostapd v0.4.9 and NetBSD 4.0

Petar Bogdanovic petar at smokva.net
Tue Apr 15 17:13:09 EDT 2008


On Tue, Apr 15, 2008 at 07:55:29PM +0300, Jouni Malinen wrote:
> On Mon, Apr 14, 2008 at 09:49:44PM +0200, Petar Bogdanovic wrote:
> 
> > I run a small AP for my flat with two ath-cards and two wireless
> > networks, sn.a (11a) and sn.g (11g) and I use hostapd v0.4.9 because
> > it's provided with NetBSD 4.0.
> > 
> > The networks work pretty well but when I try to raise the traffic (i.e.
> > bulk scp), my Linux wpa_supplicant v0.5.10 drops the connection and has
> > to reassociate/-authenticate.
> 
> wpa_supplicant and hostapd take care of authentication and encryption
> keys configuration. However, they are not actively involved with
> processing of the actual data frames. The debug logs from your setup
> seem to indicate that the driver (madwifi/net80211) on the client side
> is notifying wpa_supplicant of the disconnection. Similarly, hostapd
> debug log is showing a notification from the driver (or NetBSD net80211
> in this case, I would assume). I did not notice any problems from the
> view point of wpa_supplicant/hostapd.
> 
> This type of issue is something that will most likely require debugging
> the drivers (or kernel 802.11 implementation). You could either enable
> debug on from the client driver or from the AP net80211 code and see
> whether the reason for disconnection is reported there. I'm not very
> familiar with debugging either madwifi or NetBSD net80211 and mailing
> lists for either of those might be more suitable for getting help with
> this type of an issue.

Thanks a lot for this detailed explanation!

I will take a look at the debug output of net80211 and post the results
(including a link to this thread) on tech-net at netbsd.org.


Kind regards,

Petar


More information about the HostAP mailing list