Marvell 8686 with wpa-supplicant problem ...

Dan Williams dcbw at redhat.com
Fri Nov 2 07:04:26 EDT 2007


On Fri, 2007-11-02 at 11:08 +0800, ScottLiu wrote:
> Dan,
> 
> 	Thanks for your comment, actually Marvell provided their own WPA-supplicant called wpa-supplicant 0.4.7 in the same tar file with driver but still cannot work, so I just tried wpa-supplicant0.6.0 but the same.
> By the way, you mentioned that you worked with marvell refernece driver at this summer, I'm curious what situation when broken.
> Does it the same situation with error logs(Invalid IOCTL) in my before mail list ?
> 
> I have looked into the driver and found no mapping IOCTL number between wpa-supplicant and marvell driver.
> Does it means marvell reference driver not comply with wpa-supplicant ?

It's at least not compliant with stock upstream wpa_supplicant's WEXT
driver.  A _ton_ of the work we did with the in-tree libertas kernel
driver was specifically to make it work well with WEXT and the stock
wpa_supplicant.

Dan

> Best Regards,
> Scott Liu
> 
> 
> 
> -----Original Message-----
> From: Dan Williams [mailto:dcbw at redhat.com] 
> Sent: Friday, November 02, 2007 3:41 AM
> To: scott_liu at amit.com.tw
> Cc: hostap at shmoo.com
> Subject: RE: Marvell 8686 with wpa-supplicant problem ...
> 
> On Thu, 2007-11-01 at 11:41 +0800, ScottLiu wrote:
> > Dan,
> > 
> > System kernel version is 2.4.21, so I used Marvell reference driver.
> 
> Marvell used to provide their own wpa_supplicant driver file, you can
> find it "out there" somewhere.  I can 100% guarantee you that you cannot
> do WPA with the marvell reference driver with the -Dwext option.
> 
> When I last worked with it (this summer) the reference driver was pretty
> broken when used with wpa_supplicant.  I think Marvell has their own
> supplicant.
> 
> Dan
> 
> > I guess I can't used upstream 2.6 kernel driver, does it provide source which we can build to module of kernel 2.4.
> > Thanks you very much!
> > 
> > Scott
> > -----Original Message-----
> > From: Dan Williams [mailto:dcbw at redhat.com] 
> > Sent: Thursday, November 01, 2007 11:14 AM
> > To: scott_liu at amit.com.tw
> > Cc: hostap at shmoo.com
> > Subject: Re: Marvell 8686 with wpa-supplicant problem ...
> > 
> > On Thu, 2007-11-01 at 10:33 +0800, ScottLiu wrote:
> > >  
> > > 
> > > Hi folks,
> > > 
> > >  
> > > 
> > > I’m new to the wpa_supplicant. I tried to run wpa_supplicant 0.6.0
> > > (openssl 9.8e) with Marvell8686 SDIO wifi chip, but fail.
> > > 
> > > I know Marvell8686 works on Linux Kernel 2.6 above but I porting it to
> > > 2.4 Kenrel for some specific needs.
> > 
> > Are you using the Marvell reference driver, or the upstream 2.6 kernel
> > driver?
> > 
> > Dan
> > 
> > > Most function is just fine unless with wpa_supplicant, below is error
> > > logs,
> > > 
> > >  
> > > 
> > > # ./wpa_supplicant -c/etc/wpa_supplicant.conf  -iwl0
> > > 
> > > ioctl[SIOCSIWPMKSA]: Invalid argument
> > > 
> > > Enter wlan_setwpaie_ioctl
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl
> > > 
> > >  
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address
> > > 
> > > ioctl[PRISM2_IOCTL_HOSTAPD]: IEnter wlan_setwpaie_ioctl
> > > 
> > > nvalid argument
> > > 
> > > Failed to set encryption.
> > > 
> > > ioctl[PRISM2_IOCTL_Hret = 0
> > > 
> > > OSTAPD]: Invalid argument
> > > 
> > > Failed to set encryption.
> > > 
> > > ioctl[PRISEnter wlan_setwpaie_ioctl
> > > 
> > > M2_IOCTL_HOSTAPD]: Invalid argument
> > > 
> > > Failed to set encryption.
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_HOSTAPD]: Invalid argument
> > > 
> > > Failed to set encryption.
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address
> > > 
> > > Trying to associate with 00:50:18:21:b4:f5 (SSID='Repeat_Scott' Enter
> > > wlan_setwpaie_ioctl
> > > 
> > > freq=2437 MHz)
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl
> > > 
> > >  
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad addressEnter wlan_setwpaie_ioctl
> > > 
> > >  
> > > 
> > > failed to copy WPA IE
> > > 
> > > ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Bad address
> > > 
> > > ioctl[PRISM2_IOCTL_HOSTAPD]: Invalid argument
> > > 
> > > ioctl[SIOCSIWFREQ]: Operation not supported
> > > 
> > > ioctl[SIOCSIWESSID]: Connection refused
> > > 
> > > ioctl[SIOCSIWAP]: Network is unrEnter wlan_setwpaie_ioctl
> > > 
> > > eachable
> > > 
> > > ret = 0
> > > 
> > > Association request to the driver failed
> > > 
> > > CTRL-EVENT-TERMINATING - signal 2 received
> > > 
> > > ioctl[PRISM2_IOCTL_HOSTAPD]: InvEnter wlan_setwpaie_ioctl
> > > 
> > > alid argument
> > > 
> > > ret = 0
> > > 
> > > Enter wlan_setwpaie_ioctl
> > > 
> > > ret = 0
> > > 
> > > Enter wlan_setwpaie_ioctl
> > > 
> > > ret = 0
> > > 
> > > Enter wlan_setwpaie_ioctl
> > > 
> > > ret = 0
> > > 
> > > ioctl[SIOCSIWAP]: Network is unreachable
> > > 
> > >  
> > > 
> > > Please help me on this, any suggestion would be appreciation.
> > > 
> > >  
> > > 
> > > Scott
> > > 
> > >  
> > > 
> > > 
> > > _______________________________________________
> > > HostAP mailing list
> > > HostAP at shmoo.com
> > > http://lists.shmoo.com/mailman/listinfo/hostap
> > 
> > 
> > 
> > 
> > 
> 
> 
> 
> 
> 




More information about the HostAP mailing list