Compiling HostAP driver for 2.6.20 Kernel

Jouni Malinen j at w1.fi
Mon Jun 11 12:05:11 EDT 2007


On Mon, Jun 11, 2007 at 03:02:15AM -0700, rdu n wrote:

>         I am trying to compile 0.4.9 hostap driver to
> enable support for firmware download to my intersil
> prism chipset. But failed in compiling, it says...
> 
> echo *** Can't build for 2.6 with a non-2.6 source!
> make: *** [2.6] Error 1

Host AP driver is now included in the kernel source tree and the
external version does not support (and is not needed anyway) the latest
2.6 kernel releases. In other words, you will need to use the version
included in the 2.6.20 kernel.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list