problem with wpa_supplicant + ad-hoc mode + WPA-NONE

Thao thao710 at yahoo.com
Mon Jun 11 11:32:28 EDT 2007


Hi all,
I try to create a ad-hoc network with 3 laptops, 3 cards Wi-Fi 3COM 3CRPAG175 and WPA-NONE:

Laptop 1: Ubuntu 6.10
in /etc/network/interfaces
auto ath0
iface ath0 inet static
address 192.168.1.1
netmask 255.255.255.0
wpa-conf /etc/wpa_supplicant.conf

in /etc/wpa_supplicant.conf
eapol_version=1
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=2
network={
    ssid="testpsk"
    mode=1
    proto=WPA
    key_mgmt=WPA-NONE
    pairwise=NONE
    group=CCMP
    psk="hhhhhhhh"
}
I run:
root at laptop1:~#ifup ath0
root at laptop1:~#iwconfig ath0
ath0      IEEE 802.11g  ESSID:"testpsk"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:0F:CB:B1:82:B6   
          Bit Rate:0 kb/s   Tx-Power:31 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:A83D-9695-2E28-4D15-F1C2-9B15-2E0F-0C13   Security mode:restricted
          Power Management:off
          Link Quality=32/94  Signal level=-54 dBm  Noise level=-86 dBm
          Rx invalid nwid:43656  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Laptop 2: Ubuntu 6.10
 in /etc/network/interfaces
 auto ath0
 iface ath0 inet static
 address 192.168.1.2
 netmask 255.255.255.0
 wpa-conf /etc/wpa_supplicant.conf
 
 in /etc/wpa_supplicant.conf
 eapol_version=1
 ctrl_interface=/var/run/wpa_supplicant
 ctrl_interface_group=0
 ap_scan=2
 network={
     ssid="testpsk"
     mode=1
     proto=WPA
     key_mgmt=WPA-NONE
     pairwise=NONE
     group=CCMP
     psk="hhhhhhhh"
 }

On laptop 2, i run also:
root at laptop2:~#ifup ath0
 root at laptop2:~#iwconfig ath0

Now, 2 first laptops is connected with WPA-NONE and they can ping to eachother.

Laptop 3: Windows XP SP2
I can detect "testpsk" network but i can't connect to it.

Someone can help me, pls! 
Note that there are some errors when i run  directly :
root at laptop1:~#wpa_supplicant -c/etc/wpa_supplicant.conf -iath0 -Dmadwifi
(i saw errors on mailing list but no answer). So i try with ifup/ifdown.
Thanks alot.

Thao
   
       
---------------------------------
Choose the right car based on your needs.  Check out Yahoo! Autos new Car Finder tool.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20070611/6c617378/attachment.htm 


More information about the HostAP mailing list