Some information for users

Craig Harding craigwharding at gmail.com
Tue Jan 23 17:49:16 EST 2007


I just fixed a problem I was having with trying to connect to my own school
network and I thought I'd share with the list incase other users are having
problems similar to mine. I'm using:

ndiswrapper v1.33
wireless card: Broadcom Corporation BCM4318 [AirForce One 54g]
802.11gWireless LAN Controller (rev 02) with driver bcmwl5
(Broadcom,04/21/2005,
3.100.65.1)

The settings for the network I'm connecting to are:
  WPA, TKIP, PEAP, and MS-CHAPv2.

The problem I changed, which made all the difference, was my conf file
didn't have 'pairwise=TKIP' as one of the fields in the config section of my
network, this was ESSENTIAL for it to work (as I read on the ndiswrapper
site that talks about WPA). I also read that CCMP is the default which was
causing my problem. Anyways, adding that parameter in the config section of
my network setup fixed my problem.

So my config file is as follows:

# BEGIN WPA_SUPPLICANT CONFIG FILE
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=users
eapol_version=1
ap_scan=2    # You need this as 2 for ndiswrapper apparently.
fast_reauth=1

network={
        ssid="YOUR_NETWORK_SSID"
        proto=WPA
        scan_ssid=1
        key_mgmt=WPA-EAP
        eap=PEAP
        identity="YOUR_USERNAME"
        password="YOUR_PASSWORD"
        phase1="include_tls_length=1 peaplabel=0"
        phase2="auth=MSCHAPV2"
        pairwise=TKIP
}
# END WPA SUPPLICANT CONFIG

Craig.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20070123/47cfc6eb/attachment.htm 


More information about the HostAP mailing list