Hostapd Configuration

Jouni Malinen j at w1.fi
Wed Dec 5 22:01:07 EST 2007


On Wed, Dec 05, 2007 at 02:54:40PM -0500, Archana Rajagopal wrote:

>     I am using kernel version 2.6.16 which has inbuilt hostap driver.Is it
> possible to install hostapd 0.4.9 with this kernel.I tried doing it and when

Should be, but I would recommend using the latest stable hostapd version
(0.5.9).

> I tried the following command.
> "hostapd -B hostapd.conf"
> It gave hostap driver initialization failed.

Please try this first by running the hostapd on foreground and with
debug enabled (replace "-B" with "-dd"). This should provide more
details on what failed.

> but it created "wlanap" interface.What is this interface?

Are you sure it was "wlanap" and not "wlan0ap"? It would likely be the
interface used for management frames.

> My prism card automatically loads into interface 'wifi0' which is created by
> the system.

It should come up with two interfaces, wifi0 and wlan0.

> Moreover the network bridge(Global Sun Technology wireless network bridge)
> was loaded on wifi0 when I booted the system but since I could not ping I
> changed the network bridge to eth1 and opened a new wireless connection with
> nickname wifi0 and device eth1.Now I could ping the Access Point and could
> send traffic across it.Atleast the ping worked across the Access point.

wifi0 is not used with IP/bridging configuration. wlan0 is used for more
or less all operations that relate to network configuration.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list