Hostapd Configuration

Archana Rajagopal archana.gopal at
Wed Dec 5 14:54:40 EST 2007

    I am using kernel version 2.6.16 which has inbuilt hostap driver.Is it
possible to install hostapd 0.4.9 with this kernel.I tried doing it and when
I tried the following command.
"hostapd -B hostapd.conf"
It gave hostap driver initialization failed.
but it created "wlanap" interface.What is this interface?
My prism card automatically loads into interface 'wifi0' which is created by
the system.
But if I activate the card in master,there is a problem in pinging the
Access Point though I could see it.
Moreover the network bridge(Global Sun Technology wireless network bridge)
was loaded on wifi0 when I booted the system but since I could not ping I
changed the network bridge to eth1 and opened a new wireless connection with
nickname wifi0 and device eth1.Now I could ping the Access Point and could
send traffic across it.Atleast the ping worked across the Access point.

Is this setup correct?Also please comment on the "wlanap" interface and
whether hostapd 0.4.9 is compatible with version 2.6.16 kernel's  hostap

Archana Rajagopal
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the HostAP mailing list