help for error after changing mode

YAN HE yanhe at louisiana.edu
Fri Aug 3 10:18:42 EDT 2007


Hi, Timur,

I tried your method and it works.

Thanks,
YAN
  ----- Original Message ----- 
  From: Timur Alperovich 
  To: HostAP at shmoo.com 
  Sent: Friday, August 03, 2007 8:17 AM
  Subject: Re: help for error after changing mode


  Yan,

  I've had a similar issue and I had to reset the card to get it to work properly. You can do that with "iwpriv wlan0 reset 1". Try that. I hope it helps.

  Timur

  On 8/3/07, YAN HE <yanhe at louisiana.edu> wrote:
    Hello, Everybody,

    I met a strange problem in using hostap driver 0.4.9 for Prism cards. After I inserted the card, the driver could recognize the card and showed the general information after I ran "iwconfig wlan0". However, after I ran "iwconfig wlan0 mode Managed", the essid became empty(""). After that, whatever essid I assigned by running "iwconfig wlan0 essid essidname", the essid was always empty. When I ran "iwlist wlan0 scan", I got the error message "wlan0     Interface doesn't support scanning : Network is down". 

    The version of linux kernel is 2.6.11. I tried both Netgear MA401 16-bit card and D-Link DWL650 16-bit card, and got the same error. The detailed output is attached.

    Thanks a lot.
    YAN



    _______________________________________________
    HostAP mailing list
    HostAP at shmoo.com
    http://lists.shmoo.com/mailman/listinfo/hostap







------------------------------------------------------------------------------


  _______________________________________________
  HostAP mailing list
  HostAP at shmoo.com
  http://lists.shmoo.com/mailman/listinfo/hostap
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20070803/e007a475/attachment.htm 


More information about the HostAP mailing list