prism2_config() failed... (Consulted FAQ's and Mailing archive but still could not resolve)

Fawad Nazir fawad.nazir at gmail.com
Tue May 16 22:04:20 EDT 2006


Hi All,

I am using Ubuntu 5.10 linux v.2.6.16.6 and hostap v0.4.4 (that comes
with the kernel).
After loading this driver i inserted my PCMCIA card (Veritech
VAC2511-D Intersil Prism Chipset 802.11b complient), everything was
going ok. I checked the output of dmesg and it was:

fawad at Ubuntu-01:~$ dmesg
[4296726.711000] pccard: PCMCIA card inserted into slot 0
[4296726.711000] pcmcia: registering new device pcmcia0.0
[4296726.718000] hostap_cs: setting Vcc=33 (constant)
[4296726.718000] hostap_cs: setting Vcc=33 (from config)
[4296726.718000] Checking CFTABLE_ENTRY 0x01 (default 0x01)
[4296726.718000] IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
[4296726.718000] io->flags = 0x0046, io.base=0x0000, len=64
[4296726.722000] hostap_cs: Registered netdevice wifi0
[4296726.722000] wifi0: Interrupt, but dev not OK
[4296726.762000] hostap_cs: index 0x01: Vcc 3.3, irq 3, io 0x3100-0x313f
[4296726.962000] prism2_hw_init: initialized in 200 ms
[4296726.963000] wifi0: NIC: id=0x800c v1.0.0
[4296726.963000] wifi0: PRI: id=0x15 v1.1.0
[4296726.964000] wifi0: STA: id=0x1f v1.4.9
[4296726.965000] wifi0: defaulting to bogus WDS frame as a workaround
for firmware bug in Host AP mode WDS
[4296726.969000] wifi0: registered netdevice wlan0
[4296727.166000] orinoco 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296727.173000] orinoco_cs 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296727.179000] pcmcia: registering new device pcmcia0.1
[4296727.185000] hostap_cs: setting Vcc=33 (constant)
[4296727.185000] hostap_cs: setting Vcc=2 (from config)
[4296727.185000] Checking CFTABLE_ENTRY 0x01 (default 0x01)
[4296727.185000]   Vcc mismatch - skipping this entry
[4296727.185000] 0.1: GetNextTuple: No more items
[4296727.185000] prism2_config() failed
fawad at Ubuntu-01:~$


After looking at FAQ's and maling archive i again reloaded the driver
with ignore_cis_vcc=1.

fawad at Ubuntu-01:~$ sudo modprobe hostap_cs ignore_cis_vcc=1
WARNING: /etc/modprobe.d/my_blacklist line 1: ignoring bad line
starting with 'orinoco_cs'
WARNING: /etc/modprobe.d/my_blacklist line 2: ignoring bad line
starting with 'orinoco'

Then i was able to get rid of Vcc mismatch - skipping entry.

My dmesg now is:

fawad at Ubuntu-01:~$ dmesg
[4296859.648000] pccard: PCMCIA card inserted into slot 0
[4296859.648000] pcmcia: registering new device pcmcia0.0
[4296859.655000] hostap_cs: setting Vcc=33 (constant)
[4296859.655000] hostap_cs: ignoring Vcc=33 (from config)
[4296859.655000] Checking CFTABLE_ENTRY 0x01 (default 0x01)
[4296859.655000] IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
[4296859.655000] io->flags = 0x0046, io.base=0x0000, len=64
[4296859.659000] hostap_cs: Registered netdevice wifi0
[4296859.659000] wifi0: Interrupt, but dev not OK
[4296859.699000] hostap_cs: index 0x01: Vcc 3.3, irq 3, io 0x3100-0x313f
[4296859.899000] prism2_hw_init: initialized in 200 ms
[4296859.900000] wifi0: NIC: id=0x800c v1.0.0
[4296859.900000] wifi0: PRI: id=0x15 v1.1.0
[4296859.901000] wifi0: STA: id=0x1f v1.4.9
[4296859.902000] wifi0: defaulting to bogus WDS frame as a workaround
for firmware bug in Host AP mode WDS
[4296859.906000] wifi0: registered netdevice wlan0
[4296860.095000] orinoco 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296860.123000] orinoco_cs 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296860.127000] pcmcia: registering new device pcmcia0.1
[4296860.132000] hostap_cs: setting Vcc=33 (constant)
[4296860.132000] hostap_cs: ignoring Vcc=2 (from config)
[4296860.132000] Checking CFTABLE_ENTRY 0x01 (default 0x01)
[4296860.132000] IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
[4296860.132000] io->flags = 0x0046, io.base=0x0000, len=64
[4296860.132000] CardServices(RequestIO) returned 29
[4296860.132000] 0.1: RequestIO: Configuration locked
[4296860.132000] 0.1: GetNextTuple: No more items
[4296860.132000] prism2_config() failed

Still i was able to get rid of few errors in the end of the above output.

I have few questions:
1. Why am i getting the above errors and how can i resolve these errors?
2. In the FAQ-1 it says : "This can be enabled by setting
ignore_cis_vcc=1 in /etc/pcmcia/hostap_cs.conf". But i can not find
/etc/pcmcia/hostap_cs.conf file, should i create a new one?
3. Why the out of dmesg shows the following messages. Is orinoco
driver also being tried to load:
[4296860.095000] orinoco 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296860.123000] orinoco_cs 0.15rc3 (David Gibson
<hermes at gibson.dropbear.id.au>, Pavel Roskin <proski at gnu.org>, et al)
[4296860.127000] pcmcia: registering new device pcmcia0.1

I have already blacklisted it. But still it is listed in lsmod command.

I will be thankful for your help.

Best Regards,

-- 
Fawad Nazir



More information about the HostAP mailing list