wpa_supplicant socket error

Fabio Sangiovanni sangio.f at tiscali.it
Sat Jun 10 09:29:21 EDT 2006


Hi, I'm trying to get wpa_supplicant working on my Slackware 10.2.
The NIC is an Atheros based wireless card, so I'm using madwifi 
(perfectly compiled and loaded as modules on startup).

I've tried both compiling wpa_supplicant from source code and installing 
a binary tgz package, but with no success.

When I run wpa_supplicant -iath0 -Dmadwifi -c/etc/wpa_supplicant.conf 
-dd, I get:

Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 
'madwifi' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ap_scan=1
Line: 7 - start of a new network block
ssid - hexdump_ascii(len=7):
     73 61 6e 6a 69 6f 68                              sanjioh         
scan_ssid=1 (0x1)
mode=0 (0x0)
proto: 0x1
key_mgmt: 0x2
auth_alg: 0x1
pairwise: 0x8
group: 0x8
PSK (ASCII passphrase) - hexdump_ascii(len=8): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='sanjioh'
Initializing interface (2) 'ath0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=19 WE(source)=13 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
socket(PF_PACKET): Address family not supported by protocol
Failed to add interface ath0
State: DISCONNECTED -> DISCONNECTED
wpa_driver_madwifi_del_key: keyidx=0
wpa_driver_madwifi_del_key: keyidx=1
wpa_driver_madwifi_del_key: keyidx=2
wpa_driver_madwifi_del_key: keyidx=3
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_madwifi_set_drop_unencrypted: enabled=0
wpa_driver_madwifi_set_countermeasures: enabled=0
No keys have been configured - skip key clearing
Cancelling scan request


I think the problem is in the line:

socket(PF_PACKET): Address family not supported by protocol

There seems to be a kernel-related issue that I couldn't be able to fix.
Unfortunately, searching Google hasn't been useful.


My wpa_supplicant.conf file is as follow:

ctrl_interface=/var/run/wpa_supplicant
#ctrl_interface_group=0
ap_scan=1

network={
   
   ssid="sanjioh"
   scan_ssid=1
   mode=0
   proto=WPA
   key_mgmt=WPA-PSK
   auth_alg=OPEN
   pairwise=TKIP
   group=TKIP
   psk="xxxxxxxxx"
}


Kernel  2.6.16.20.

Thanks a lot for helping me.



More information about the HostAP mailing list