Having problem on wpa_supplicant with EAP-TTLS

Jouni Malinen jkmaline at cc.hut.fi
Sat Jul 29 21:22:04 EDT 2006


On Wed, Jul 26, 2006 at 04:48:41PM +0200, Paul-Henri Gauzence de Lastours wrote:

> I'm using wpa_supplicant-0.4.8.
> The version of OpenSSL is 0.9.7j, the latest for branch 0-9-7 (4th may
> 2006), and I'm working on ARM9 with a 2.6.10 kernel.

Is this using uClinux? Which C library are you using?

> According to what you say, the problem should come from OpenSSL, so I'm
> gonna have a look on it.

Either something goes wrong in the way OpenSSL library is being called
or something odd happens in OpenSSL. Have you used OpenSSL on that
board with anything else?

I haven't tested OpenSSL 0.9.7j, but I would not expect it to be that
different from earlier 0.9.7 versions that I have tested. It looks like
this issue may require adding some more debug code in eap_tls_common.c
or tls_openssl.c to figure out what exactly is happening when OpenSSL
library gets called.

-- 
Jouni Malinen                                            PGP id EFC895FA



More information about the HostAP mailing list