wpa_supplicant and madwifi - IEEE80211_IOCTL_SETMLME fails

thomas schorpp t.schorpp at gmx.de
Mon Jan 16 22:47:43 EST 2006


Chip Salzenberg wrote:
> I've been using wpa_supplicant successfully for a long time with the
> hostap driver.  (It's the Debian binary of 0.4.7.)
> 
> But now I've upgraded to an 802.11g card, the D-Link DWL-G650.  I
> installed the madwifi driver and plugged in the card, and so far
> everything was peachy.  But when I ran wpa_supplicant with the options
> 
>    -i ath0 -D madwifi -c /etc/wpa_supplicant.conf
> 
> It doesn't work.  It mostly seems to work, it detects the correct
> ESSID and tries to associate, but then there's an ioctl failure:
> 
>    ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
> 
> What info should I provide to help you debug this?  Or is this a known
> problem?
> 
> PS: I compiled wpa_supplicant 0.5.0 and tried it -- same exact results.

more info needed.

i have the same card.

it works here with the madwifi-ng svn and wpa_supplicant cvs from a hour ago.

so keep with cvs/svn HEAD versions.

im just trying to reproduce the driver oopses on autoreset and in the processtriggers function / hal  
i had for the last days. i thought the card was damaged but it works fine so far.
im waiting for the autoreset on hw error.

no issues so far only a ioctl[unknown???] warning with wpa2-enterprise connected to 0.4.7 hostapd 
running madwifi-old.







More information about the HostAP mailing list