wpa_supplicant and madwifi - IEEE80211_IOCTL_SETMLME fails

Dimitris Kogias dimitris at gmail.com
Mon Jan 16 22:33:07 EST 2006


> It doesn't work.  It mostly seems to work, it detects the correct
> ESSID and tries to associate, but then there's an ioctl failure:
> 
>    ioctl[IEEE80211_IOCTL_SETMLME]: Invalid argument
> 

Since you saw the same result when building sources yourself (against
the same headers that correspond to your running modules) it's unlikely
to be a build mismatch.

Which madwifi revision are you running?  It may have been caused by
revision [1394]:

http://madwifi.org/changeset/1394

Is the interface UP at the point the ioctl call is made?

FWIW, I hit the same problem but with hostapd instead.  I run two
virtual access points, managed by the same hostapd process and two
config files.  hostapd is happy with ath0, but fails on ath1.  I made
sure the interface was UP before hostapd was run but had no luck.

The gory details are in this madwifi ticket:

http://madwifi.org/ticket/316

but I don't know enough to tell if this is a madwifi or a
hostapd/wpa_supplicant bug.

[1393] avoids the problem for me, for now.

D.



More information about the HostAP mailing list