can't get wpasupplicant to authenticate against router using wpa-psk

Jason Carr jason at flacid.org
Tue Feb 14 22:38:40 EST 2006


I think I'm having the same problem, but with WPA-RADIUS.  It used to
work now it doesn't at either of the locations I use WPA.

What linux distro and kernel version are you running?  What wireless
card are you using?

I'm running ArchLinux, kernel 2.6.15.4, ipw2915 (kernel's ipw2200
drivers... 1.0.8-git)

Here's some quasi logs... what else can I do to help out to figure out
what the problem is?

Feb 14 21:58:52.374089: Selecting BSS from priority group 0 
Feb 14 21:58:52.374105: 0: 00:13:10:68:b7:d2 ssid='flacid.org'
wpa_ie_len=30 rsn_ie_len=26 caps=0x11 
Feb 14 21:58:52.374126:    selected based on RSN IE 
Feb 14 21:58:52.374145: Trying to associate with 00:13:10:68:b7:d2
(SSID='flacid.org' freq=0 MHz) 
Feb 14 21:58:52.374162: CTRL_IFACE monitor send - hexdump(len=23): 2f 74
6d 70 2f 77 70 61 5f 63 74 72 6c 5f 32 39 37 32 2d 30 00 00 00 
Feb 14 21:58:52.374194: Cancelling scan request 
Feb 14 21:58:52.374211: WPA: clearing own WPA/RSN IE 
Feb 14 21:58:52.374226: Automatic auth_alg selection: 0x1 
Feb 14 21:58:52.374246: RSN: using IEEE 802.11i/D9.0 
Feb 14 21:58:52.374261: WPA: Selected cipher suites: group 8 pairwise 24
key_mgmt 1 
Feb 14 21:58:52.374277: WPA: set AP WPA IE - hexdump(len=30): dd 1c 00
50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 04 00 50 f2 02 01 00 00 50 f2
01 01 00 
Feb 14 21:58:52.374302: WPA: set AP RSN IE - hexdump(len=26): 30 18 01
00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 01 00 00 0f ac 01 01 00 
Feb 14 21:58:52.374326: WPA: using GTK TKIP 
Feb 14 21:58:52.374342: WPA: using PTK CCMP 
Feb 14 21:58:52.374358: WPA: using KEY_MGMT 802.1X 
Feb 14 21:58:52.374373: WPA: Set own WPA IE default - hexdump(len=22):
30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 01 00 00 
Feb 14 21:58:52.374396: No keys have been configured - skip key
clearing 
Feb 14 21:58:52.374411: wpa_driver_wext_set_drop_unencrypted 
Feb 14 21:58:52.374428: State: SCANNING -> ASSOCIATING 
Feb 14 21:58:52.374443: wpa_driver_wext_associate 
Feb 14 21:58:52.374476: Setting authentication timeout: 10 sec 0 usec 
Feb 14 21:58:52.374498: EAPOL: External notification - portControl=Auto 
Feb 14 21:58:52.374541: Wireless event: cmd=0x8b06 len=8 
Feb 14 21:58:52.374570: Wireless event: cmd=0x8b1a len=19 
Feb 14 21:58:52.390377: RX ctrl_iface - hexdump_ascii(len=4): 
     50 49 4e 47                                       PING            
Feb 14 21:58:52.681958: Wireless event: cmd=0x8b15 len=20 
Feb 14 21:58:52.682494: Wireless event: new AP: 00:13:10:68:b7:d2 
Feb 14 21:58:52.682517: State: ASSOCIATING -> ASSOCIATED 
Feb 14 21:58:52.682537: Associated to a new BSS:
BSSID=00:13:10:68:b7:d2 
Feb 14 21:58:52.682553: No keys have been configured - skip key
clearing 
Feb 14 21:58:52.682570: Associated with 00:13:10:68:b7:d2 
Feb 14 21:58:52.682585: CTRL_IFACE monitor send - hexdump(len=23): 2f 74
6d 70 2f 77 70 61 5f 63 74 72 6c 5f 32 39 37 32 2d 30 00 00 00 
Feb 14 21:58:52.682613: WPA: Association event - clear replay counter 
Feb 14 21:58:52.682629: EAPOL: External notification - portEnabled=0 
Feb 14 21:58:52.682655: EAPOL: External notification - portValid=0 
Feb 14 21:58:52.682681: EAPOL: External notification - portEnabled=1 
Feb 14 21:58:52.682696: EAPOL: SUPP_PAE entering state CONNECTING 
Feb 14 21:58:52.682710: EAPOL: SUPP_BE entering state IDLE 
Feb 14 21:58:52.682725: EAP: EAP entering state INITIALIZE 
Feb 14 21:58:52.682740: EAP: EAP entering state IDLE 
Feb 14 21:58:52.682769: Setting authentication timeout: 10 sec 0 usec 
Feb 14 21:58:52.682804: RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1'
added 
Feb 14 21:58:53.358609: Wireless event: cmd=0x8b15 len=20 
Feb 14 21:58:53.358654: Wireless event: new AP: 00:00:00:00:00:00 
Feb 14 21:58:53.358674: Setting scan request: 0 sec 100000 usec 
Feb 14 21:58:53.358695: BSSID 00:13:10:68:b7:d2 blacklist count
incremented to 2 
Feb 14 21:58:53.358712: State: ASSOCIATED -> DISCONNECTED 
Feb 14 21:58:53.358739: EAPOL: External notification - portEnabled=0 
Feb 14 21:58:53.358754: EAPOL: SUPP_PAE entering state DISCONNECTED 
Feb 14 21:58:53.358769: EAPOL: SUPP_BE entering state INITIALIZE 
Feb 14 21:58:53.358784: EAP: EAP entering state DISABLED 
Feb 14 21:58:53.358809: EAPOL: External notification - portValid=0 
Feb 14 21:58:53.358835: CTRL-EVENT-DISCONNECTED - Disconnect event -
remove keys


On Tue, 2006-02-14 at 23:06 +0100, Andreas Berglund wrote:
> Hi!
> 
> I'm having some problems with wpasupplicant. I can't get it to
> authenticate against my wireless router using wpa-psk. I'm using a
> netgear wg311t with madwifi. I know it works because I have gotten it to
> work before.
> 
> This is the message i get when starting wpasupplicant and running wpa_cli.
> "<2>Trying to associate with SSID 'myssid'"
> "<2>Authentication with xx:xx:xx:xx:xx:xx timed out."
> 
> And if I run status in wpa_cli this is what I get:
> sid=xx:xx:xx:xx:xx:xx
> ssid=myssid
> pairwise_cipher=TKIP
> group_cipher=TKIP
> key_mgmt=WPA-PSK
> wpa_state=ASSOCIATING
> Supplicant PAE state=DISCONNECTED
> suppPortStatus=Unauthorized
> EAP state=DISABLED
> 
> The versions of the software I'm using are
> kernel: 2.6.15
> wpa_supplicant: 0.4.0-1
> madwifi: revision 1391
> 
> The modules loaded pertaining to madwifi are:
> wlan_scan_sta
> wlan_tkip
> ath_pci
> ath_rate_sample
> wlan
> ath_hal
> 
> I have attached my wpa_supplicant.conf to the end of the message.
> Thanks in advance for any help.
> 
> regards
> Andreas Berglund
> 
> 
> 
> ctrl_interface=/var/run/wpa_supplicant
> eapol_version=1
> fast_reauth=1
> 
> ap_scan=2
> network={
>         ssid="mysid"
> 	scan_ssid=1
> 	proto=WPA
> 	key_mgmt=WPA-PSK
> 	#pairwise=CCMP TKIP
> 	pairwise=TKIP
> 	#group=CCMP TKIP WEP104 WEP40
> 	group=TKIP
>         psk=xxxx.....
> }
> 
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> HostAP mailing list
> HostAP at shmoo.com
> http://lists.shmoo.com/mailman/listinfo/hostap




More information about the HostAP mailing list