wpa_supplicant: WPA: EAPOL-Key Replay Counter did not, increase - dropping packet

Joey Richards joey at caltech.edu
Tue Feb 14 03:09:43 EST 2006


Jouni,

Thanks for your reply.  Unfortunately, I don't have access to any other 
wireless LAN hardware so I don't expect to be able to capture a 
3rd-party log of the activity.  I'll see what I can do, but I don't 
expect it any time soon.

Would it be helpful to try wpa_supplicant under Windows XP?  The normal 
Windows XP wireless manager doesn't have any trouble staying connected 
indefinitely.

I also checked the AP manufacturer's website and confirmed I'm using the 
latest firmware.

joey


hostap-request at shmoo.com wrote:
> Send HostAP mailing list submissions to
> 	hostap at shmoo.com
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://lists.shmoo.com/mailman/listinfo/hostap
> or, via email, send a message with subject or body 'help' to
> 	hostap-request at shmoo.com
> 
> You can reach the person managing the list at
> 	hostap-owner at shmoo.com
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of HostAP digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: wpa_supplicant: WPA: EAPOL-Key Replay Counter did not
>       increase	-	dropping packet (Jouni Malinen)
>    2. Re: wpa_supplicant: WPA: EAPOL-Key Replay Counter did not
>       increase -	dropping packet (Jouni Malinen)
>    3. Re: wpa_supplicant crashes under Windows XP (Jouni Malinen)
>    4. Re: setting wpa_supplicant on windows XP??? (Jouni Malinen)
>    5. Re: Netgear Router DG834GTB & ndiswrapper driver (Jouni Malinen)
>    6. Re: Sometimes ap_scan=2 and sometimes not... (Jouni Malinen)
>    7. Re: Distance settings (Jouni Malinen)
>    8. Re: wpa_supplicant v0.4.7/0.5.1 authentication timeout /
>       disassociate	/	associate loop (thomas schorpp)
>    9. Re: wpa_supplicant v0.4.7/0.5.1 authentication timeout /
>       disassociate	/	associate loop (thomas schorpp)
>   10. Re: hostap-driver 0.4.7 and Prism2 PCMCIA initialization
>       failure:	"wifi0:	hfa384x_cmd: entry still in list?"
>       (Aleksander Adamowski)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sun, 12 Feb 2006 19:32:19 -0800
> From: Jouni Malinen <jkmaline at cc.hut.fi>
> Subject: Re: wpa_supplicant: WPA: EAPOL-Key Replay Counter did not
> 	increase	-	dropping packet
> To: hostap at shmoo.com
> Message-ID: <20060213033219.GA8579 at jm.kir.nu>
> Content-Type: text/plain; charset=us-ascii
> 
> On Sun, Feb 12, 2006 at 07:20:09PM +0100, Shawn Adams wrote:
> 
>> I've got the same issue, strange enough wpa_supplicant 0.5.0 functions
>> fine , same access point - Nortel 2220, as long as I use the Dell 1450
>> built-in adapter using ndiswrapper with bcmwl5a. it works with both
>> WPA-PSK, and WPA-EAP
>>
>> If I use the same wpa_supplicant, same /etc/wpa_supplicant.conf, it
>> fails using a PCMCIA wireless card using madwifi drivers, which fails
>> with both WPA variants.
>>
>> only difference is that my card never connects - the "replay counter"
>> errors come immediately, and constantly.
> 
> That is interesting. The first attempt should not really fail due to
> replay counter error.. Could you please send a debug log from
> wpa_supplicant (with -dd on command line) for both these cases
> (ndiswrapper and madwifi)? 
> 



More information about the HostAP mailing list